I recently bought a new MacBook to replace my iMac where used Microsoft Office for Mac. I set up my MacBook and transferred everything over, but couldn't run Office without the activation key.

I deleted and installed a trial of office 365, and used until the trial expired. Now I think I have the activation key (from looking it up—it's the same as the product ID?) I tried moving over from a backup, but I'm getting the Office 365 activation, and does't accept the code I have.

I have tried migration assistant and replacing the library files but nothing. I keep getting this screen now matter what I try:

Can I move the original Microsoft Office suite over from the iMac to my new MacBook any other way to stop getting this massage? I think I got as a download years ago, so no disc.

  • Without the activation key you may be out of luck. If you got Office as a download, you might have received the key via mail so it may still be in your mailbox somewhere.
    – nohillside
    Aug 18, 2014 at 11:44
  • Duplicate? apple.stackexchange.com/questions/142250/… Aug 18, 2014 at 13:24
  • @AlistairMcMillan The OP already followed the steps recommended in the linked question/answer and seems to still have problems.
    – nohillside
    Aug 18, 2014 at 13:54
  • @patrix Totally aware of that. Isn't it better to just update the original question though? Aug 18, 2014 at 13:56
  • Have you ever actually purchased an Office key or Office365 subscription? That is not clear from your question.
    – smoooosher
    May 6, 2015 at 18:18

2 Answers 2


I am also using Microsoft Office 2008 on a new 5K iMac which is running Yosemite and I used Dropbox to get it onto the Mac –no key and no migration assistant.
It runs perfectly.
Microsoft tried to tell me that Yosemite was not compatible with office 2008 but that is not the case in my experience.


Your version of MS Office must be at least 2011 to run in Mavericks, which is probably the OS on your new Mac.

  • I am using MS Office 2008 on Yosemite. It was also running on Mavericks... :-)
    – user106602
    Dec 29, 2014 at 18:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .