0

When I try to start gdisk on my retina MacBook Pro running Mavericks I get the following error:

dyld: lazy symbol binding failed: Symbol not found: __ZN3icu13UnicodeStringC1Ev
  Referenced from: /usr/sbin/gdisk
  Expected in: /usr/lib/libicucore.A.dylib

dyld: Symbol not found: __ZN3icu13UnicodeStringC1Ev
  Referenced from: /usr/sbin/gdisk
  Expected in: /usr/lib/libicucore.A.dylib

I have used gdisk on this machine a number of times before (last time was probably a few months ago) and am not sure what would have changed to cause this issue. The modified time stamp of libicucore.A.dylib is July 4, 2014, so maybe something changed in an update. Unfortunately, my time machine backups don't go back far enough to try to revert to the previous version.

The other day I upgraded an older Mac Mini to Mavericks and gdisk is working fine on there. I even tried copying the library over to the laptop, but that didn't help.

Any thoughts on what could be going wrong and what needs to be done to fix it?

1
  • How did you install disk - in my Mavericks it is not there and ONLY Apple supplied code should be in /usr/sbin - when installing it did it corrupt /usr/lib ? – mmmmmm Aug 18 '14 at 12:36
1

Well I certainly feel foolish...

Somehow in never occurred to me to check that both computers were running the same version of gdisk. It turns out that the version on my laptop is a few versions older than the one on my mac mini and between those versions gdisk was updated to not use libicu because "it seems to have broken somewhere along the line" (according to change log). Upgrading to the newer version fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .