1

I was messing around with using AppleScript for GUI manipulation so the apps I was making had to be granted access. The very first one I did showed up in Security & Privacy > Accessibility as 04F05B1B-23E7...6027D697DF.app (not the name of the app). So I copied it's contents, deleted the app, and made a new one with the same name. That worked (it showed up in Security & Privacy > Accessibility as the correct name), but the other name was still there, even though the app was gone. AND if I tried to check the box to allow it to control my computer, it would instantly uncheck itself. So not only should it not be there, but it performs weird as well. Now that was my only problem until today, when I noticed that every single one of the apps I had made had its name transformed into some string of numbers, capitol letters, and hyphens. So I copied the folder the apps were in to some other spot and deleted the originals, that didn't make them go away. Then I zipped up the copy folder and deleted the unzipped one, that didn't work either (yes I have restarted my computer). I have no idea how to fix this and I didn't have any success trying to google it, so here I am. Here's four of the five that exist.

picture of names of apps

EDIT: Also, could anyone tell me if files related to those applications left on my computer is the reason the apps won't leave.

1

Within Terminal you can run the following command to see the current entries in your system.

sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'select * from access'

And then this command to remove an entry you don't want any longer.

sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%YOURAPPNAMEHERE%"'

So, for example, I ran the following command which removed Automator from the list.

sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%Automator%"'

And just to give credit where credit is due, I found the solution on Apple's discussion forums here.

Another option to find a list of applications which have requested Accessibility access is the following command. This will give you the list of application which have been allowed and the ones that haven't.

defaults read com.apple.universalaccessAuthWarning
  • The apps are supposed to be deleted by themselves correct? – Mason Aug 18 '14 at 4:52
  • If you delete the application from your Mac it should automatically disappear from the list. If it doesn't disappear then that suggests something remains. Try the last command I just added to the answer above. That might help identify where the files are. – Alistair McMillan Aug 18 '14 at 7:30
  • So if I made an AppleScript app and deleted it, what would remain on my computer? Were talkin just a simple one script file application here. – Mason Aug 18 '14 at 17:26
  • could I just delete that database and reset everything? – Mason Aug 19 '14 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .