1

My iPhone 5s CONTINUALLY downloads songs I've previously purchased, then deleted. I've resolved the issue on how to delete songs that appear un-deletable. Now I need to stop the songs from downloading. The other day, it wasted my entire month's data by downloading 350 songs while I was listening at work.

Here's my info:

1) I don't use iCloud for music.

2) "Show All Music" option is off.

3) I don't subscribe to iTunes Match.

4) I sync only one (1) playlist, with 1061 songs, the other day it jumped to 1405 songs.

5) "Automatically fill free space with songs" has NEVER been on.

6) "Automatic Downloads" is turned off for music.

7) I have deleted the library through Settings, and re-synced several times.

8) I have 7.1.2 on my phone and 10.9.4 on my iMac.

9) Songs appear while I'm listening to music.

10) I don't manually manage songs.

  • Do you have any third party apps installed that might be the culprit? Is it a jailbroken device? – Ian C. Aug 17 '14 at 17:31
1

Go to Settings → Cellular (Mobile) and switch Music off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .