1

I have a mid-2010 Macbook Pro with 10.9.4. I've been using it with a Seiki 39" 4K TV as a monitor for about a month now with no problems. (This is using an UltraAV MDP to HDMI Active Adapter cable.) For the first time yesterday I selected "1080p" as the resolution in Display Preferences to see what it looked like. Immediately after going to 1080p resolution, the list of resolutions went blank. I could click (or option-click) on the scaled circle, and there would be a delay of a few seconds, then I'd see a list of resolutions flash up, and then go away. Based on what I later figured out, I think if I had tried to click one of those selections when they flashed up, I would have gotten out of 1080p mode. But I did something else, trying to reset the display preferences to a normal state. (I don't remember what exactly)

From then on, the Mac seems to think it's talking to a dumb TV. It only lets me select 1080p, 720p, and two other resolutions. Additionally I get a slider for "Underscan" which tells me it thinks it's talking to a TV in some sort of "TV-mode". I don't see the full set of resolutions going up to 4k that I was seeing before. Here is what I've tried with no joy:

  • reinstall jumbo update for 10.9.4 (no help)
  • updating firmware on the TV
  • reseting TV to factory standard
  • logging in as another user (still see 1080p)
  • Resetting the PRAM
  • logging in in Safe Mode (this works!)

I'd like to remove/reset/review all the non-user files that are different or new since the base OS was installed (counting updates).

The only other thing I can think of is to reinstall the whole machine.

Any ideas short of that?

Update: Option-clicking the "Scaled" choice enabled about 10 additional choices, which are all smaller than 1080p. But still no 4k choices, and I still get a slider for Underscan, so it's still in 1080p mode.

I tried the SwitchResX app, and it might have had a way to help, but I wasn't able to figure out how to do what I wanted. The normal default operations didn't seem to allow the resolution I wanted.

0

Try clicking on "Scaled" while holding the key.

Regular click: Display settings pane

+ click: enter image description here

  • That definitely helped me with my fiddling. – Chris Quenelle Aug 25 '14 at 16:07
0

Here is what I did to get my screen working.

  • Remove /Library/Preferences/com.apple.windowserver.plist
  • Remove /Users/yourusername/Library/Preferences/ByHost/com.apple.windowserver.*
  • Reset PRAM

This didn't immediately fix the problem, but I tried rebooting into safe mode to make sure that still worked. I switched resolutions around in safe mode. I rebooted into regular mode.

Eventually I saw a resolution option I hadn't seen before. It was something like "740 x 1200 (HiDPI mode)." I selected that, and then the mode flipped away from "dumb 1080p" and it gave me a the range of high resolutions I had before.

It seems that HiDPI is Apple's name for a "retina display" driver.

So now I think the OS must have some sort of binary flag to puts you in HiDPI mode. My problem was that the flag got turned off, and I didn't have an easy way to turn it back on again. If I'd known that earlier I would have tried setting a properties flag like:

sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true

I found that described here: http://cocoamanifest.net/articles/2013/01/turn-on-hidpi-retina-mode-on-an-ordinary-mac.html

I got my display working again, but if I needed to dig deeper into it, I would learn more about HiDPI mode.

0

I was having problems with a MBA11 macOS Sierra(10.12) and DELL U2715H. It was using the 2560x1440 resolution but it was always applying underscan (image was not using the whole panel).

I installed SwitchResX 4.6.0 and then finally, after digging for a few minutes through all those options, I found what I wanted: SwitchResX Preferences > Menus > Menu Extra - Display overscan/underscan (checkbox)

Now when I click the icon I can see the slider to adjust image size! The app has many other funcionalities and, at this moment, costs 14€.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .