4

I recently ran into a very persistent bug on my iPhone 5 on iOS 7.1.2. All of the sudden the flashlight button in the control center is greyed out and the rear camera wont work, i.e. showing a black screen and crashing. According to the Apple forums I am not alone with this issue. For some people playing around with the camera worked. Most end up bringing the phone to the store. I am pretty convinced it is a software bug.

I tried so far (list will be updated):

  • Play around with camera settings (flash, HDR, ...)
  • Turn flashlight on/off with third-party app - app crashes
  • Regular iPhone restore from iTunes
  • Recovery mode firmware restore

No success. I have no more warranty and so I can't bring it to the store. Does anyone have further ideas or even the solution?

  • If you have done a Recovery mode firmware restore, what's your basis for thinking it's a software bug? – samh Aug 16 '14 at 23:01
  • Yeah - you are probably right :( Denying the ugly truth I guess. – n1000 Aug 20 '14 at 6:38
1

If you have done a Recovery Mode firmware restore and you still can't use the flashlight or camera, you likely have a hardware problem. Make an appointment at the Genius Bar and see if they can identify the specific failure (no charge for a diagnostic at least in the U.S.).

  • Thanks - will check if diagnostics are free in Europe as well. – n1000 Aug 20 '14 at 6:39
0

Any possibility you've gotten some moisture into the phone? These are the same symptoms exhibited by my iPhone 5 after a brief dunk and recovery via desiccator. The rear cam and flash unit never worked again, stalling on initialization, and sometimes crashing the camera app. When I brought it to the Apple Store, the genius said the contacts for the camera were somewhat corroded. I elected to get a new phone rather than pay the price for repair. Hope you have better luck.

  • Thanks for the answer. No moisture - at least not recently. However, I did use the phone in the rain from time to time though, so maybe it is also a slow corrosion problem. – n1000 Aug 20 '14 at 6:37
0

I checked all the external sensors, and they all appeared red meaning water damage, so I'm assuming that may be the problem. Even though you haven't had your phone in water or anything, it possibly drew water damage, the best thing to do is to take it to a professional and have it looked at.

-1

My flashlight button greyed out but I didn't check the camera's function. I just powered off my iPhone and when I powered it on again, the flashlight button was functional again.

-1

My torch icon was grey and not working but flash on camera fine. Turned phone off and back on and it fixed itself (iPhone 6)

  • The OP already addressed that. – samh Mar 30 '16 at 1:39
-1

Mine was the same after iOS update. Turned phone off and was working fine when I turned it back on again.

  • Welcome to Ask Different! This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Tetsujin Apr 1 '16 at 14:52

You must log in to answer this question.

protected by bmike Apr 1 '16 at 13:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .