10

I welcome popup spelling suggestions, but I dislike the OS replacing text as I type without any real confirmation from me.

I'm aware both behaviors can be enabled/disabled together as one option in System Prefs > Keyboard > Text, but would anyone know a way to disable the autocorrect while leaving the tooltip-style suggestions intact…perhaps via the Terminal? Thank you.

Mac OS X 9.4 (Mavericks)

1

When a suggestion happens and the word is underlined in blue, then right click the word and goto Spelling and Grammar and uncheck Correct Spelling Automatically.

  • Close, but that only works on an app-by-app basis. I want a system-wide change. – jtheletter Nov 3 '15 at 22:00
0

i think you have to stop word Prediction in your iPhone, or iPad.

So, you have to go with below settings,

  1. Go to the Setting app.
  2. Then, Tap on general option.
  3. Then disable Prediction option. (turn off toggle).
  • Sorry, I tagged this for Mac OS X. I'll edit my question to make it more clear. – jtheletter Aug 16 '14 at 7:11
  • what's your OS version? from where you are facing like mail, act... – user280426 Aug 16 '14 at 7:15
  • Mavericks (I'll update question above). Autocorrect happens in all apps (it's system-wide, part of the OS). – jtheletter Aug 16 '14 at 7:52
0

I havent found a solution either, but as a crude workaround you can use something like popclip, which also provides correction

0

There is another crude workaround I use - right click, Spelling and Grammar, Show Spelling And Grammar. All suggestions will be there. It is better than popups if you do not need suggestions too often.

0

I tried going into System Preferences --> Keyboard --> Text (uncheck) "Correct Spelling Automatically"

It seems to have worked (so far) - I still get the option to correct without it automatically correcting (or autocorrecting to a word that was not a real word), at least in my emails, which was my biggest problem.

  • As said in my question, both behaviors (autocorrect and spelling suggestions) are disabled by unticking this checkbox. – jtheletter Apr 28 '16 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .