-1

I have a MacBook 13" (A1181) running Mac OS X 10.6.8, I have a problem with the battery

When its turned off it responds to power button only when charger plugged in.

After starting i can remove the charger, and it keeps working on the battery.

But there is an x on the battery, and it shows

No Batteries Available

Power Source: Battery

I've tried the following:

  • I checked the battery with an other mac, and every thing was fine

  • I did SMC reset with no results

  • I even replaced the battery cable and the magsafe

Nothing resolved the problem

What should i try now??

Any idea will be helpful

Thanks

1

Your SMC reset did not work.

Check your SMC reset procedure.

You have a 5 Years old battery!- it is EOL, get a new one.

  • As I told its not the battery, because on other mac it works fine. For SMC reset I did the process described at support.apple.com/kb/ht3964 1-Shut down the computer 2-Disconnect the MagSafe power adapter from the computer, if it's connected 3-Remove the battery 4-Press and hold the power button for 5 seconds 5-Release the power button 6-Reconnect the battery and MagSafe power adapter 7-Press the power button to turn on the computer – Ould Abba Aug 15 '14 at 15:45
  • A 5 Years old battery is not fine! It might work for a short while. Publish your battery profile from the about this Mac. – Ruskes Aug 15 '14 at 21:05
  • There is no battery profile in the About this mac section. It says battery not installed, even that i can work on the battery for an hour!! – Ould Abba Aug 17 '14 at 14:20
  • I have an other macbook of the same model, i tried switching pieces of the both macs but no thng works. Now i'me sure the problem is in the logic board, i dont think its a hard problem, it should be the PRAM – Ould Abba Aug 17 '14 at 14:23
  • When i switch the PRAMs the computer doesn't even start. Do you know why? – Ould Abba Aug 17 '14 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .