This is an issue that I run across every time I modify my two-step verification settings in Gmail or set up a new phone. I've asked this question to Google enough times. Now I think I'm qualified to ask it to myself.

If you've set up Gmail as your default Mail app account and you use two-step verification, then Mail won't work if you haven't properly set up your device (and you might not even know it's not working if you're using the Gmail app as your main mail app until you try to share via email something in another app and realize it never gets sent).

There doesn't seem to be a simple user-friendly answer to this problem out there, so after running into this issue and solving it yet again, I figured I'd write out instructions for others to follow.


2 Answers 2


So you've already set up two-step verification in Gmail...

(If not, now is probably a good time to do so.)

But now that you have 2-step enabled, you can't use your old gmail password to sync your iOS Mail app to Gmail. You will have to sign into Gmail on your phone using a special app password which you can find by signing into Google at your two-step settings page:


Then click the "App-specific passwords" tab, and then the "Manage application specific passwords" button.

At this point you may see that you've already set up an app password for your device, but if you've recently reconfigured your two-step settings or activated a new phone, then you'll need to "Revoke" access and set up a new app password.

Set up a new app password for Mail by selecting "Mail" on my "iPhone" (or other iOS device) in the dropdowns and click "Generate".

Next, follow the directions provided by Google:

  1. Open “Settings” on your iPhone.
  2. Select “Mail, Contacts, Calendars”.
  3. Select your Google Account from the list of available accounts.
  4. Edit your account information and replace your password with the 16-character password shown below.

It's as easy as that.

  • Bingo. This is what I do to configure YouTube on my Rokus, Apple TVs, and iOS devices. Commented Dec 4, 2014 at 17:51
  • In iOS v9.1 the Settings / Mail-Contacts-Calendars / Gmail / Account screen has no password field for your Gmail account. So after setting up 2-factor authentication, how do you change the password? You must convince it to put up its own screen (webpage) that accepts your gmail username and gmail password (NOT a generated app password), then it texts you a code and requires you to enter it, then it finally caches some credentials. Sorry that this is a little vague, it worked for me today but I didn't log each step. Commented Dec 9, 2015 at 13:15
  • 1
    The process to generate the app specific password seems to have changed. The steps are outlined here: lifewire.com/…
    – CodeNaked
    Commented Aug 24, 2017 at 15:46
  • Link referenced no longer goes to the proper place to generate app passwords, but this answer got me on the right track. Thanks.
    – Art Geigel
    Commented Sep 26, 2018 at 1:11
  • I eventually ended up at myaccount.google.com/apppasswords
    – ojchase
    Commented Oct 27, 2019 at 2:08

This helped me a lot, thanks. But iOS has evolved a bit since v9.1. To get to the Mail account setting in iOS v14.7:

  • Go to Settings > Mail > Accounts
  • Select your Gmail account
  • Select your Gmail account again
  • Replace INCOMING MAIL SERVER password with your new 16-character app password.
  • Click Done.

You should start seeing emails syncing in your Mail app.

  • 1
    iOS 14 also allows you to properly login to google via a web popup. Commented Jul 31, 2021 at 2:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .