1

I have a WD MyBook World NAS with the set static ip 192.168.0.102 (subnet mask 255.255.255.0) - it might be also defined that the router ip is 192.168.0.1 but I can't remember. It works great on my home network.

Now I took the device with me somewhere else and want to connect it directly to my MBP (running Mavericks) with ethernet cable. I just can't ping the NAS.

I have tried sharing my internet connection from the wifi to ethernet. Nothing.

I have tried setting the manual ip on the ethernet port in NetworkSettings to 192.168.0.1 (subnet 255.255.255.0). Nothing.

Can anyone please help?

  • Connecting your NAS directly to your macbook, with ip addresses in the same range (192.168.0.x) should work. So are you sure your NAS ip is 192.168.0.102? Do you have the capability to connect using USB cable? What does the manual say? – CousinCocaine Aug 14 '14 at 10:38
  • Hi CousinCocaine thank you for your reply. I am 100% sure my NAS ip is 192.168.0.102. As I have said setting my ip to 192.168.0.1 does not work, neither does 192.168.0.100 for instance. I do not have a manual, a this is quite old and I threw it away. – Reggian Aug 14 '14 at 10:57
  • I have a Buffalo NAS with static IP and able to connect to using my MBP. Also iTunes recognizes the NAS with DLNA. I don't remember doing anything in special to connect. – KK99 Aug 14 '14 at 11:13
  • Here is your manual: wdc.com/wdproducts/library/UM/ENG/4779-705013.pdf – CousinCocaine Aug 14 '14 at 16:29
1

Does system preferences show a network connection? You'll be counting on it switching to crossover mode - it's possible the NAS is interfering with that. Are you defining a router IP within system preferences? Make your machine ip 192.168.0.100, router 192.168.0.1, subnet 255.255.255.0, then try a ping.

If that doesn't work, post the output of this command: route -v get 192.168.0.102

0

I do not know what the problem was. But I have solved my problem by pressing the reset button and it went to normal DHCP mode. It works fine from there. I just have to reconfigure some stuff back.

Thanks everyone.

  • I'm not sure why someone would down vote your answering your own question, but I appreciate you following up and explaining things... – bmike Aug 14 '14 at 20:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .