4

This is really weird. Whenever my sister-in-law calls my wife via FaceTime, my phone and Mac also ring at the same time. When my wife answers the call, then both of my devices stop ringing.

It's exactly as if all three devices were using the same Apple ID for FaceTime, but they're not, and they never have. My wife's phone is signed into her iCloud account and uses her phone number and email address for FaceTime; likewise, my phone and Mac are signed into my iCloud account and use my phone number and email address.

Furthermore, this only happens when my sister-in-law calls, not anyone else.

Why does this happen, and how can I prevent it? The only thing I can think of is that maybe my sister-in-law has both my wife's phone number and my phone number in the same contact card, so when she starts a FaceTime call, it goes out to both our numbers (and my Mac by extension)?

  • 3
    Since it only happens with your sister-in-law, I would start there with the trouble-shooting. And, I think your hypothesis is where I start as I've seen similar (but not exact) situations before. Ask her to create two totally separate and distinct contacts for you and your wife. Retest, and please let us know how it works. – tim.rohrer Aug 14 '14 at 2:17
  • 1
    It may not be phone number but rather your email address that your sis-in-law has in the wrong contact. – samh Dec 18 '15 at 1:54
2

Yes - this technology seems to be driven by your contact card info stored by calling party. If calling party has info for you and someone else in same contact card, then both phones will ring for FaceTime even if not same Apple ID.

In our case, we had friend who had stored my number and husband's number (not email) under my contact card. Both our phones would ring when friend tried to FaceTime me, even though husband and I have separate Apple IDs and caller never selected the other number.

Solved it by having calling friend remove the additional phone number from my contact card on his machine.

0

She has more than one email associated with your contact info. Get her to remove the one that is not commonly used.

-1

based on the information that I've read from the Apple forums, go into settings>facetime> and turn your iphone cellular calls off. Do this on both devices, this should stop the calls from going to both devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .