1

I'm running 10.9.4 on a MacBook Air, and when I enter composition mode in Scrivener (which is a full-screen mode) I find that the Mac Notification Center is completely disabled. Any alerts I receive will make no sound and I can't see the little windows. If I switch away from Scrivener to another app, then the alerts are visible, but any banners have already come and gone, so I never see them.

Is there any way to change this behavior? I would like Notification Center to stay active even when I'm in this full-screen app.

Thanks!

  • This is not the default behavior. I entered composition mode and still received an alert. I also tested this behavior using "Banners." See here. I suggest resetting composition mode settings to default. I also suggest testing the behavior in another user account if it persists to isolate it further. – njboot Aug 14 '14 at 3:26
  • 1
    Thanks for showing me it's at least possible. I tried resetting composition mode settings, but that didn't work. I did a bit more research, and finally discovered that I have to first put Scrivener into regular full-screen mode, then put it into composition mode. This apparently gives Scrivener its own Space separate from the Desktop Space, and then it leaves Notification Center alone. A bit kludgy but it works. Interestingly, it doesn't work in Word 2011, which kicks itself out of OSX fullscreen mode before it enters composition mode, and so continues suppressing notifications. Sigh. – mayostard Aug 14 '14 at 16:20
2

I found an imperfect solution: apparently applications that use their own full-screen mode (an older API maybe?) and not the OSX full-screen mode, disable the Notification Center while they're in full-screen. Scrivener's composition mode does this, as does Word 2011.

A solution that worked for me in Scrivener was to go into regular full-screen mode (View->Enter Full Screen), which uses the OSX full-screen API, creating its own Space for Scrivener, putting the blue full-screen icon on the right-hand side of the menubar, and leaving Notification Center intact.

If I then go into composition mode (View->Enter Composition Mode), all is well and Notification Center works.

Note, this doesn't work in Word, because in its infinite wisdom, it kicks itself out of OSX fullscreen mode, ditching its Space, before it enters composition mode. So I still don't know how to receive notifications while composing in Word, but maybe that's just another reason not to use Word.

Thanks to njboot for the screenshot showing it was possible to get notifications in Scrivener composition mode!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .