1

When running pmset -g, the sleep value (putting the system to sleep) is set to 1 (sleep prevented by coreaudiod)

  • I have set my screen saver to show after 10 minutes of inactivity.
  • I then set my display to shutoff after 20 minutes.
  • I then modified the disksleep value to 20 minutes as well.

At this point, I noticed that I get this "warning":

Warning: Idle sleep timings for "AC Power" may not behave as expected. - Display sleep should have a lower timeout than system sleep.

This is because my displaysleep is 20 and my sleep is 1. Can this be explained, why is system sleep set to 1, what does this really mean?

3

Per the pmset man page:

sleep - system sleep timer (value in minutes, or 0 to disable)

So, your computer (Mac Pro, I'm assuming by the question tag) is set to sleep the system after one minute, but other sleep functions that depend on the system (putting the display to sleep, putting the disk to sleep, etc.) are set to run after the system is supposed to sleep. How can the screensaver start after 10 minutes if the entire system is already sleeping after 1 minute??? :D

To change this, you can run sudo pmset sleep <number of minutes>. So, to set the system sleep value to zero minutes (turning off sleep) on my own system, I run sudo pmset sleep 0. If you want to do it through the GUI, you go to System Preferences > Energy Saver, and toggle the "Computer Sleep" value.

  • The default value for my Mac Pro was 1, I'm trying to understand why. – Brian Graham Aug 13 '14 at 17:03
  • @BrianGraham Well, if you feel like pouring through logs, run pmset -g log and see if you can find when/where the new value was set? – thankyour Aug 13 '14 at 21:39
0

I had a similar question on my MBA 10.11.6. System sleep = 1 min for batt and AC although display sleep set at 2 min, 15 min, respectively. Didn't understand how system sleep could be < display sleep time. I found an explanation here.

A quote:

The System Information app shows that the Air’s system sleep time has been pre-set to just one minute. This doesn’t mean your machine will go into hibernation after that period, rather that’s when it tells Haswell to doze off...

...Looking at the machine, with its display still active, you’d never know; start clicking on anything and the CPU wakes up. If there’s any lag while it does so, it’s not detectable by a human being: your typing, say, is there as soon as you hit the keys. Pause to reflect on what you’ve just written, however, and after a minute, back to sleep goes Haswell...

This was written about 2013 MBA but seems to apply here. I got rid of system sleep=1 by changing Energy Saver pane settings and setting them back again (unchecked then re-checked Prevent computer from sleeping when display is off for AC power). Of course there is also pmset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .