6

I just reinstalled OSX 10.8, and I've encountered an incredibly odd behaviour: binding cmd+\ to "Move focus to next window" doesn't work (if I hit it, I get the "pop" error sound). However, binding it to other actions works, and binding other combinations to that action also works.

This makes no sense to me.

I would rather keep using this shortcut, as I'm quite used to it and I hit it often.

Does someone have any clue?

P.S. in case it might help: this did work in my previous 10.8 install.

Update: doesn't work in 10.10 either: I don't get the "pop" error sound anymore, but it just does nothing.

3
  • What keyboard-layout are you using? It does work on a german keyboard just FYI Aug 20, 2014 at 21:12
  • @KevinGrabher I've noticed the German layout has ^ in place of `\`, so maybe that's why it works? I'm using a custom-made layout, but it doesn't work even with plain Italian layout neither with plain Japanese layout, so the layout itself isn't the problem.
    – o0'.
    Aug 20, 2014 at 21:17
  • Not a true answer, but might KeyCue help? Does using the other Command key have the same effect? If you key Command then use Character Viewer to click the on-screen \ key, does that allow the Command-\ shortcut to used where required? Aug 20, 2014 at 21:28

1 Answer 1

5
+25

For what it is worth, I am able to bind +\ to Move Focus to Active or Next Window in Mavericks, and it works fine for switching between Finder windows.

move focus

(It doesn't help your situation except to indicate that this might be a bug...)

If you are trying to use it in another application besides the Finder, does the standard +` work?

I have the Full Keyboard Access option below that set to text boxes only:

keyboard access

EDIT: Reassigning +\ to "Move focus to next window" also works fine for me.

You are probably onto something with the backslash causing the problem, since defaults write -globalDomain NSUserKeyEquivalents -dict-add "Move focus to next window" '@\' gives an error Could not parse: "@\". Try single-quoting it. and trying to escape it with a backslash results in a strange dictionary assignment:

$ defaults read -globalDomain NSUserKeyEquivalents
{
    "Move focus to next window" = "@\\\\";
}
5
  • Doesn't work in the Finder either. If I select US layout and set <kbd>⌘</kbd>+<kbd>`</kbd> as combination it works, but as I said it works anyway with any other combination which isn't that one. "Text boxes" only selected here too.
    – o0'.
    Aug 21, 2014 at 22:00
  • The custom layout still seems suspect to me, since it works on other layouts. Command back tick is a default for window switching in most apps, without any mods. Does that work in your layout before assigning it?
    – beroe
    Aug 22, 2014 at 0:02
  • But as I said it doesn't work in other standard layouts either. It's the backslash who is causing the problems, for some reason. Can I maybe edit the keybindings via text file, just to check they are escaping them correctly?
    – o0'.
    Aug 22, 2014 at 9:49
  • I've just noticed: I don't care about "Move focus to active or next window", though it doesn't work either. I care about "Move focus to next window". It's a different command.
    – o0'.
    Aug 24, 2014 at 9:05
  • I've run defaults write -globalDomain NSUserKeyEquivalents -dict-add "Move focus to next window" "@\\\\", and now defaults read -globalDomain NSUserKeyEquivalents returns "Move focus to next window" = "@\\\\";, but it still doesn't work...
    – o0'.
    Aug 25, 2014 at 19:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .