3

I just upgraded my old Macbook Air (late 2010) from 10.6.8 to Mavericks 10.9.4. The OS now sees three ghost monitors that do not exist:

Ghost monitors

When I'm cordless, I can work around by mirroring the monitors, but I typically work with multiple monitors where mirroring is pointless.

I found a few references to this problem online (particularly here). I followed the directions from the first link (reset PRAM, detect displays, no joy). Additional information

  • The other monitors are all called "built-in display".
  • Under the hardware system report (About This Mac-> More Info-> System Report -> Graphics Displays), I find only the LCD monitor attached to the Mac.
  • 'Detect displays' still detects the same phantom displays.
  • An external monitor works, but I still see the three phantom monitors.

Questions Are there any available solutions or workarounds? For example:

  1. Can I use software to disable the extra monitors?
  2. The poster in the second link above got joy with graphicsenabler = YES options in Chameleon. Can I replicate that setting that in my situation?
1

I came up with a workaround when I was finalizing the question: mirror only the phantom displays. To do this, go to System Preferences-> Displays and click Arrange (click gather windows if you don't see an option to mirror displays).

While holding the Option key, drag the windows that you wish to mirror on top of one another. (In my case, I mirrored all of the phantom monitors on top of one another.) Release the option key and arrange the other monitors as you like.

  • Wow, this effectively works for me. OSX still thinks I have 3 displays instead of 2, but the phantom one and the real one are mirrored, so at least my windows don't get lost and my mouse cursor doesn't go off into the phantom display. However, I wonder if I'm still wasting CPU/GPU time drawing things twice... – chaqke Jun 23 '15 at 18:24
0

I had the same problem with my Mac Pro 2008 running El Capitan. Mike McCoy's workaround didn't work for me, but it inspired a solution. I positioned my phantom display diagonally adjacent to my real display. My mouse can still escape to the phantom desktop, but only through the bottom right corner "portal." As long as all of my apps keep appearing on my real screen, I'll be OK.

Yes, this is a cr@ppy workaround, but after three hours of web research and trying a dozen suggestions, this is the best that I can do.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .