0

When I do (as root):

./autogen.sh

I get this error:

+ glibtoolize --copy --force
./autogen.sh: line 44: glibtoolize: command not found

And then when I do this:

./configure --enable-developer-warnings --enable-debugging-symbols

I get this error:

configure: error: Package requirements (libpcre) were not met:

No package 'libpcre' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PCRE_CFLAGS
and PCRE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Does anyone know how to solve this?

I tried installing Varnish with homebrew and I got this:

sudo brew link pkg-config pcre
Error: Cowardly refusing to `sudo brew link`
You can use brew with sudo, but only if the brew executable is owned by root.
However, this is both not recommended and completely unsupported so do so at
your own risk.

This was recommend that I do before installing.

1

The easiest solution is to use a package manager like brew.

Download and install it using the installer on their website.

And then simply brew install varnish. It will download and install all the prerequisites for you.

5
  • I tried did not work. I tried with Mac Port and got version 3 when the version now is 4.0.1. – jnbdz Aug 10 '14 at 17:48
  • varnishd (varnish-3.0.4 revision 9f83e8f) Copyright (c) 2006 Verdens Gang AS Copyright (c) 2006-2011 Varnish Software AS – jnbdz Aug 10 '14 at 17:49
  • Yup. The macports version is out of date. The brew version is 4.0.0. What happened when you tried to use brew? – Alistair McMillan Aug 10 '14 at 17:54
  • Many problems. It just keeps coming. I will add some of the errors I got from Homebrew in my question. – jnbdz Aug 10 '14 at 18:18
  • 1
    Just try "brew install varnish" on its own. No "sudo". And you don't need to install dependencies first. That's one of the reasons for a package manager, it'll install the dependencies for you. – Alistair McMillan Aug 10 '14 at 19:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .