Is there a way to set the brightness for all displays (thunderbolt displays) connected to a mac using thunderbolt syncroniously.

If I chnage the brightness using F1/F2 on my Mac Wireless Keyboard. Only the Main screen is affected. But I want the displays to stay syncronized.

Any way thought?


This won't let you adjust all of the screens but works for alternates

ctrl-F1 and ctrl-F2 usually change the brightness on the other display (or external display on 10.7).

  • 1
    ctrl-F1 (brightness key) worked for me. Thanks. – Lokesh Dhakar Sep 4 '15 at 16:54
  • 1
    fwiw I'm using a MacBook Pro (Retina, 13-inch, Late 2012) running OS X El Capitan with a 27-inch Thunderbolt Display, also from late 2012, and ctrl-F1 | ctrl-F2 works for me. – maml Nov 11 '15 at 20:30

Can I change the brightness on a secondary display? This thread (although the question is slightly different) offers answers to your question.

  • Event though Shades doesnt work for me, Control + F1 or Control + F2 will adjust the brightness on a secondary display. Nevertheless this also quite randomly. It doesn't sync brightness on all screens. If I use a third Display (MacBook Air) then I can controll the brightness of MacBook Air and one of the randomly selected Thunderbolt Displays. But not on both Thunderbolt Displays and not on all three Displays. Thanx but this is not what I wanted. – Nicolas Schwarzentrub Aug 9 '14 at 16:28
  • You can use the MacBook's keyboard to change the internal screens brightness. And the primary display should be the one where the dock is I believe, although it could also depend on which screen your active window is. I have no setup to test it unfortunately. – Kevin Grabher Aug 10 '14 at 17:52

The hack I used to adjust multiple thunderbolt displays (I use two external displays in addition to my Macbook's built in for a total of three) is to adjust the random Thunderbolt using ctrl+f1/f2 and then unplugging that one and then I'm able to adjust the other with ctrl-f1/f2. When I plug in the other display the brightness setting returns to what I had set it at.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .