1

Opened messages and the crash reporter immediately opened stating that the program crashed. In the reporter it stated:

Sandbox Creation Failed: You do not have permission to save the file "Application Support" to the folder "Library".

After some research the only possible solution I found involved creating a temporary account to see if its the system or user library and possibly having to delete your current account and creating a new, slightly different account and move your files to that new account.

My question was, is there an easier way to fix this without having to go through so much trouble?

(Hint: There is, or at least it worked for me. Read on to the answer.)

  • Unfortunately, I have to wait to post my answer to my question because of this "reputation system". Stay tuned. – JoshT Aug 9 '14 at 5:04
1

Usually I activate the Guest account and use that to test issues like you're describing.

If you try with the Guest account and you're successful, it is an indicator that you've got permission problems with your files.

Unfortunately, Apple's Disk Utility doesn't fix users' files. I've generally found it is quickest to go into the terminal.app and look for permissions that seem out of the ordinary. For example, Application Support folder on my MBP is rwx------

You can view yours by opening Terminal, using cd Library to get into the right folder, then ls -lh to view the folders including Application Support.

If those permissions are different, we can show you how to change them.

  • I actually had an answer for this and unfortunately, until I get 10 reputation (unbelievable) I have to wait 8 hours to answer my own question. It is actually a simple method of just fixing the permissions using chmod in the terminal. – JoshT Aug 9 '14 at 5:53
  • Excellent. Same place I was going. Glad you were able to figure it out! – tim.rohrer Aug 9 '14 at 11:41
0

Ok, so this is the solution that worked for me. No guarantees it'll work for you, but it's worth a shot compared to having to recreate your account.

First off, open Terminal. You can do this by either typing Terminal in the Spotlight, or going to Applications > Utilities > Terminal.app. From there a window will open and you will type sudo chmod 755 ~/Library/Application Support (you will have to enter your password), or if you want to make sure you have permissions to everything in your library folder you can type sudo chmod 755 ~Library/* and this will change the permissions of everything in your library folder to rwxr-xr-x (viewed by typing ls -la or -le in the terminal. If you have other users on your computer, you can substitute 700 in place of 755 and your permissions will be rwx------.

As I said, it was an instant fix for me so feel free to give it a try. It might save you some trouble.

Additionally, if this doesn't completely fix the problem, you can also remove the plist file that is associate with the program. This can be done by going to Library > Preferences and in this case searching for com.apple.iChat.plist and deleting the file or, if you're still in the terminal, type sudo rm ~/Library/Preferences/com.apple.iChat.plist

0

I found two different solutions to the crashing Apple Messages problem.

  1. Make sure that McAfee Endpoint Solutions specifies that Messages is allowed under Application Protection. This worked for me.
  2. For those not using McAfee: I am not sure of its validity because the McAfee solution worked in my case. Solution two is to run the FontBook app, and ensure that AppleGothic font is enabled, not duplicated, and validated (you validate it from the "File" menu).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .