19

Ok I get how to disable Image Capture from opening for a specific device, but I'm an iOS developer and I work with a lot of devices. Is there a way to stop this ruddy app from launching the first time I connect any new device? It's a serious invasion of privacy when I connect someone's phone and immediately see their photos plastered on my screen for the world to see!

3

One solution might be to use Cameras from Flexibits.

Install this preference pane and set "When you connect new cameras:" to "Do nothing" and it should stop your Mac from automatically opening Image Capture when you connect a new device.

Note that Flexibits don't update it anymore, and don't even offer it on their website but in the limited testing I was able to do it does still seem to work. Also since it isn't updated any longer it's a 32-bit preference pane so you'll get that "To use ... preference pane, System Preferences must quite and reopen." when you open it. However you only need to open it once to set the "When you connect new cameras:" option.

  • Thanks for the answer. I tried it out and will mark this as the answer if it works. – devios1 Aug 10 '14 at 22:31
24

Actually, the best way is:

Once Image Capture is open, click the device in the list, then: Bottom left corner of the application, small triangle. There: switch it to "no application".

Done

  • It's the "once it's open" part I'm trying to avoid. – devios1 Jan 30 '15 at 0:31
  • do it once - and never see it again :) – reflog Jan 30 '15 at 10:57
  • 2
    Did any of you even read the question? Geesh. – devios1 Mar 26 '15 at 22:02
  • this answer doesn't seem to be working anymore on el Cap. Image capture will launch, just not mount the phone... – sas08 Oct 11 '15 at 4:49
  • I wanted to downvote this because it doesn't answer the question. However, I'm afraid it's impossible to disable the opening of Image Capture for all devices. The only way which seems to work is to set the pref. for every single device or memory card as described here. – mivk Jan 31 '16 at 13:29
2

You have to open iPhoto, go into iPhoto Preferences and next to Connecting camera opens: select No Application.

enter image description here

enter image description here

  • The only downside will be that this applies to all devices and if you want to download pictures using Image Capture you will have to open it manually, which can be easily done from Spotlight. – JoshT Aug 9 '14 at 6:41
  • 1
    Alas, I don't have iPhoto, nor do I want it. – devios1 Aug 9 '14 at 23:05
  • 1
    I hear ya. I don't use it myself. Used to, but not anymore. The other option is to disable it per unit on image capture itself. There's there's a button on the lower left corner of the program. Hope it helps. – JoshT Aug 10 '14 at 2:01
2

You can also change the permission and remove any access rights on the application package/folder. I used this on iTunes as well to prevent it from starting when pressing play and not having Spotify open.

Its as easy as using chmod from Terminal

sudo chmod 000 /Applications/Image\ Capture.app

or rightclicking the app, opening the info window, scrolling to the bottom of the view and changing them there.

More info on chmod: http://www.chriswrites.com/how-to-change-file-permissions-using-the-terminal/

  • This way you can no longer open the app even with Launcher! :( – madlymad Jan 13 '16 at 9:08
  • True. But you could use Alfred or create an apple script etc to toggle the setting. Think of it as having the safety on :) – Lohardt Jan 13 '16 at 14:07
1

This seems to work in OS X 10.9.5:

defaults -currentHost write com.apple.ImageCapture2 HotPlugActionPath ''

Not sure if -currentHost is really needed, or if it would also work without it.

What I had also tried, which seems to work for some but didn't for me:

defaults -currentHost write com.apple.ImageCapture disableHotPlug -bool YES

Maybe it depends on the OS version.

  • The currentHost option wasn't required but it now is. It's probably safe to include everywhere it doesn't throw an error when you issue the command. – bmike Mar 3 '16 at 16:33
0

Yes, deleting the app indeed does work. So it's got that going for it which is nice.

However, I renamed the offending application to "Image Capture.disabled" to fix the problem.

  • 1
    This 'hack' completely deletes the Image Capture app from the user's computer. Not the best 'answer' by far - more like slash & burn. – IconDaemon Feb 17 '15 at 18:38
  • yeah, renaming is a better path. – dwightk Feb 17 '15 at 18:47
-1

You could delete Image Capture entirely through the Terminal command

sudo rm -rf /Applications/Image\ Capture.app/
  • 1
    While this would indeed stop Image Capture from opening (because it would delete the program), it's often a dangerous course of action to delete system files. This program is a part of the operating system, and deleting it could break other components of the system that expect it to be present. – Daniel Jan 7 '15 at 18:46
  • @Daniel That's purely speculative. I've used many OSX machines with it deleted and have had no issue (and that's purely experiential). – Joseph Lennox Apr 2 '15 at 18:21
  • That's great. What I'm saying, and yes it's hypothetical, is that any future system update might rely on it being there. I'm glad it hasn't caused you any problems so far. – Daniel Apr 2 '15 at 18:22
  • In theory system updates could expect it to be present, but in my experience, at least with major version updates they just replace Photos and iTunes even after I've deleted them. So then I go and delete them again. No problems so far! – Dupe_jockey Jun 3 '15 at 17:46
  • 1
    It's great that you've had no problems so far. However, this doesn't mean that most users won't run into problems with this solution in the future, especially when they might need Image Capture in the future. If you really want to offer this solution, I would recommend something reversible, like sudo mv '/Applications/Image Capture.app' '/Applications/Image Capture.app.disabled' or sudo chmod a-x '/Applications/Image Capture.app/Contents/MacOS/Image Capture'. – interestinglythere Sep 2 '15 at 9:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .