7

I'm running into this really strange problem on my 2013 iMac at home (running Mavericks): the internet will work for a while, then at some point it will stop being able to load any websites except for Facebook and Google (and Google-owned sites, like Gmail and YouTube). These sites work fine, but attempting to access any other site will get stuck on "Connecting..." and eventually time out.

This applies to all browsers. It also applies whether I'm connected via ethernet or WiFi.

Attempting to ping other sites like amazon.com, bing.com, etc. via ping just shows a string of timeouts. nslookup does seem to give back IP addresses, but even plugging these directly into a browser's address bar, I still get nothing.

So I guess that means it's not a DNS issue? All the same, I've tried my ISP's default DNS, Google DNS, and OpenDNS -- no difference.

I can confirm the problem is just with my iMac. Other devices on the same network can connect to any website just fine. Furthermore, if I actually start up a Windows VM on the iMac, the VM can also connect to any website!

Rebooting the computer fixes things for a while. But eventually the problem comes back.

Does anyone know what the issue might be? I've Googled around a bit, and it does seem that some people have encountered similar issues; but I wasn't able to find any solutions that worked for me.

EDIT: Maybe this is the same issue as in this question. However, bouncing mDNSResponder as prescribed in the top answer to that question didn't solve the problem for me.

  • We need to look in to something (someone) blocking your access – Ruskes Aug 8 '14 at 20:08
  • Does your internal IP address change after rebooting? – MrWhite Aug 8 '14 at 22:21
  • @w3d: You mean like what I see if I run ifconfig? – Dan Tao Aug 10 '14 at 22:02
  • @w3d: If so the answer appears to be no—it stays the same (192.168.1.83). – Dan Tao Aug 10 '14 at 22:35
  • Ah OK, I was was just wondering whether it was anything to do with your internal IP address being blocked somehow... but I guess not? (You mentioned that rebooting temporarily fixed the issue. Depending on your network/DHCP server, rebooting might have assigned you a new IP address.) – MrWhite Aug 10 '14 at 23:45
2

This may unique to my case, but I had exactly this problem today. My Macbook Pro (OSX 10.9.4) started to not connect to anything except google and facebook. No other websites worked. This happened at home and it happened with both wireless and ethernet connections. I took the computer into my office thinking it might be my home ISP, but same problem at the office. Then I remembered that yesterday I reinstalled a Cisco VPN client. As soon as I uninstalled it, everything started to work again - both in my home and office, wifi and ethernet.

2

For me, changing the DNS to Google DNS solved the problem. Google DNS is 8.8.8.8 or 8.8.4.4. You can change DNS number in the modem/router settings or your own device on which you are connected to internet. If its your own modem/router better change it there. If it is public network where you don't have access to modem/router settings, you can change the DNS in your device for that particular connection.

2

In my case the problem was IPv6. Websites like Facebook, Google.com and Youtube use IPv6 and work fine while other's don't support it yet.

I couldn't figure out the issue exactly (and the right configuration for IPv6) but I disabled IPv6 and the issue was resolved. This is all I care at this point.

The commands for El Capitan:

Turning off IPv6 support for ethernet:

networksetup -setv6off Ethernet

Disabling IPv6 for wireless:

networksetup -setv6off Wi-Fi

If you ever need to re-enable:

networksetup -setv6automatic Wi-Fi
networksetup -setv6automatic Ethernet

I will edit this if I ever find the correct setting for IPv6 instead of a full disable.

  • Running networksetup -setv6off Wi-Fi fixed this issue for me when I suddenly encountered it using my 2015 macbook running OSX Sierra a coffee shop. Thanks! – Ian Walker-Sperber Jun 27 '18 at 20:27
0

I tried many things suggested by google using phone data (and spent too much time). Nothing worked. Then unplugged router, let sit, plugged back in. Success! Should always start with turning it off and on again... I have a mac with El Capitan.

0

To those still having problems similar to this, here are my findings. Thought I'd post it up as I didn't find a single answer to this problem that worked for me.

I'm on a Macbook Air and one specific wifi network I connect to seems to have connection issues to any site other than Google or Facebook. It would seem that the firewall was the fault with my config. Blocking Inbound ICMP requests (Stealth Mode in the OS X Firewall settings) seemed to be causing a problem with the automatic Path MTU Discovery. I thought Auto PMTUD only needed outbound ICMP, but disabling the Inbound filter fixed the issue.

You can also cross verify the problem with PMTUD by manually setting the MTU in your advanced network settings to something lower than the default 1500. If dropping it down to 1400 or 1300 resolves the problem, you may have something in your network path blocking ICMP requests which PMTUD relies on. Remove all ICMP blocking on your system firewall and router firewalls to see if that resolves the issue. Disabling Stealth mode in OS X Sierra worked for me. Again, I thought PMTUD only needed outbound ICMP, but apparently that's not the case.

0

I've tried all of the above with limited success (sometimes works, sometimes does not).

The reason why you are able to load Google and Google-owned sites and bigger players like Facebook is because they use IPv6 and not only IPv4.

The issue seems to occur almost every time I wake my Macbook from sleep.

The only solution I've found to work instantly and every time is going into Preferences > Networks > Click the lock icon & enter your password > Advanced > TCP/IP > Click "Renew DHCP lease".

-1

For me, changing the DNS to Google DNS solved the problem. Google DNS is 8.8.8.8 - this worked for me too!

-2

Go to setting --> network --> revert and it worked !

  • 2
    Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is right. It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 11 '17 at 19:52

You must log in to answer this question.

protected by Tetsujin Oct 19 '18 at 7:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .