I've got a Mac Mini running the latest version of OS X Server, and two iMacs. Both iMacs are the same model (Mid 2007 20-inch, 2 Ghz Core 2 Duo). On one of the Macs I have installed 10.9.4 and installed all of our software, and I used it to make the NetRestore image on the server. I've tried the image on other (newer) Macs around and it seems to work fine, but when I try to run it on this second iMac (which is identical to the original iMac that I made the image from), it fails. Does anyone have any ideas about what might be going on or how to go about fixing it?

Install Failed OS X could not be installed on your computer The restore operation failed. Select "Startup disk…" or restart to try again. Click Restart to return to your previous version of OS X. Restart

  • We are having the same issue here. We thought maybe it was hard drive size, server configuration, etc. We are trying to get it to work as well. Try booting the device and choose startup disk to boot onto the netrestore image. We just got a machine that was failing to restore correctly after doing this method.
    – user87674
    Commented Aug 13, 2014 at 19:14

3 Answers 3


I ran into the same issue, and finally figured out the trouble is related to the CoreStorage partition type that is shipping with Yosemite.

To solve the NetRestore issue, first boot into a recovery mode (either the built-in recovery drive, an external USB drive, or net recovery).

Open up Terminal, and run these two commands:

diskutil cs list
diskutil cs revert A-Long-string-of-hex-values

The first command will print a tree view of the CoreStorage drive. Of note, you should see a few long UUID strings. Likely there would be one for "Physical Volume", "Logical Volume Family", and "Logical Volume". It is the string after the last one ("Logical Volume" which you should copy and paste as A-Long-string-of-hex-values in the second command.

See http://awesometoast.com/yosemite-core-storage-and-partition-woes/ and The OS X Man Page for diskutil for a bit more info. (Note that some sources may use "coreStorage" in place of "cs" in the above commands. According to the man page, the two are equivalent)



We had a similar issue while building images for our various Elementary Schools that cropped up this year. Some images would work and some wouldn't. We first thought it had something to do with the various model computers we were using to create the images, i.e. building the image on a MBA 2013 and trying to apply to a 2012 MBA model, but that ended up being a dead end.

Just yesterday I made a discovery and I'm not sure if it will work in your situation but maybe it is worth looking into. We noticed that when we took a computer that had a 120GB SSD and created a 10.9.4 image and then tried applying that image to a similar model MBA computer which the only difference was a 60GB SSD vs. the 120GB SSD the NetRestore would fail w/o any log errors. Once we moved that original image over to 60GB SSD drive using Carbon Copy Cloner and then setup a new saved NetRestore from that computer and tried the same process over the image was successful.

I know you mentioned in your post that they were similar models, but I'm hoping just maybe this fix will work for you. Good luck! -Ken


You need to set the system time This article should help...

When you’re booting your Mac from the recovery partition and are planning to reinstall OS X, you might be met by the following message:

An error occurred while preparing the installation. Try running again

Now, if you haven’t used your Mac for a while, the error might be caused by an incorrect system date setting. You can check this by going to utilities and opening the terminal. Once in the terminal enter the following command and hit return/enter:

date The result of this command will be the date that the system currently has been set to. For some reason, it might have been reset to 2001, in which case we need to set it to the right date. To do this, we enter a new command. This command will be entered as follows:

date {month}{day}{hour}{minute}{year} Every bracket should be replaced with a two-digit number. For example, March 18th 2013 12:50 would become the following command:

date 0318125013 Enter the command and hit return. You can then check if it was set correctly by running the first command again. If the date was wrong, it was likely that which caused the error, and after you quit the terminal it should be able to install OS X just fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .