10

I have have a MacBook pro late 2010 (now 4 years old), I use it everyday and there's a graphical issue where letters in the browser become blurry and broken, some kind of weird glitch happens all the time.

Problem

Whenever I scroll on a page or write content in an input, using google chrome letters become like this (click on the picture so you understand what happens).

glitchy macbook pro mid 2010 graphic on google chrome

This is very disturbing when reading.

What I tried

Other browsers

They work a bit better

I have tried on Opera browser and on Safari and this doesn't happen (at least, did not happen as often as chrome). I used firefox for a while now, went better, but Playing videos on firefox does the glitch too. I switched to Firefox Developer Edition and can't tell when was the last time I experienced an issue (see end of question and answers, may help too).

Disabling plugins

Nope. I created a new chrome user (with no plugin installed), still does that flickering.

Reinstalling Chrome

Nope. Tried this multiple times, still the same.

Trying other versions of Chrome

Nope. Thought it worked fine, used it for 30 minutes, does the same again.

chrome canary glitching

Additional informations

I am currently running Yosemite but it's been doing this for a long time.

Hardware Overview:

  Model Name:   MacBook Pro
  Model Identifier: MacBookPro6,1
  Processor Name:   Intel Core i7
  Processor Speed:  2.66 GHz
  Number of Processors: 1
  Total Number of Cores:    2
  L2 Cache (per Core):  256 KB
  L3 Cache: 4 MB
  Memory:   8 GB
  Processor Interconnect Speed: 4.8 GT/s
  Boot ROM Version: MBP61.0057.B0F
  SMC Version (system): 1.57f17
  Serial Number (system):   ***
  Hardware UUID:    ***
  Sudden Motion Sensor:
  State:    Enabled

Intel HD Graphics:

  Chipset Model:  Intel HD Graphics
  Type: GPU
  Bus:  Built-In
  VRAM (Total): 288 MB
  VRAM (Dynamic, Max):  10
  Vendor: Intel (0x8086)
  Device ID:  0x0046
  Revision ID:  0x0018
  gMux Version: 1.9.22

NVIDIA GeForce GT 330M:

  Chipset Model:  NVIDIA GeForce GT 330M
  Type: GPU
  Bus:  PCIe
  PCIe Lane Width:  x16
  VRAM (Total): 512 MB
  Vendor: NVIDIA (0x10de)
  Device ID:  0x0a29
  Revision ID:  0x00a2
  ROM Revision: 3560
  gMux Version: 1.9.22
  Displays:
Color LCD:
  Display Type: LCD
  Resolution: 1600 x 1000
  Pixel Depth:  32-Bit Color (ARGB8888)
  Main Display: Yes
  Mirror: Off
  Online: Yes
  Built-In: Yes

Things that seemed to help

These are taken from the answers below (thanks!), read them for details

  • I had some unusual cpu usage after upgrading to yosemite, I followed 6 Easy Tips to Speed Up OS X Yosemite on Your Mac (first one helped alot).

  • I disabled hardware acceleration in chrome about:config

  • I enabled subpixel font rendering for non-Apple LCDs:

     defaults write NSGlobalDomain AppleFontSmoothing -int 2
    
  • Just so you know: the picture is not a link, so clicking on it does nothing. – Chris Mukherjee Aug 7 '14 at 13:57
  • 1
    Which version of OS X are you running? – Paul Gilfedder Aug 7 '14 at 13:59
  • 2
    Have you tried uninstalling Chrome and reinstalling? Use something like AppCleaner to uninstall it, that way you can make sure you get all (or at least most) of the files that might get left behind. – Chris Mukherjee Aug 7 '14 at 14:08
  • Or if you don't want to download the app, use this guide to manually find all the files in your Library folder. – Chris Mukherjee Aug 7 '14 at 14:09
  • 1
    Since you mentioned that the error occurs only on Chrome, and not on other browsers: make sure you're using a stable version of Chrome. When/If you uninstall and reinstall make sure you download and install the latest stable build, and NOT the beta (Notice that the two download pages are very similar...) – Chris Mukherjee Aug 7 '14 at 14:22
2

I have experienced the same glitch.

This seems to be the problem reported here: https://code.google.com/p/chromium/issues/detail?id=359108

They claim it's an issue with Mavericks, GPU-accelerated graphics, and the NVIDIA GeForce GT 330M. I also have a mid-2010 Macbook Pro with the same graphics chip

This glitch started happening on mine after I upgraded to Mavericks. Also my Macbook started rebooting spontaneously every couple of weeks, with kernel panic messages about the GPU.

The suggested workaround is to go into Chrome's advanced settings, and disable the checkbox for "Use hardware acceleration when available" (second from the bottom). Then restart Chrome.

I just tried that myself, so I can't report that it works reliably yet.

  • Thanks, indeed, this is the same problem you have found. I finally switched to firefox because of this, but I'll give this a try. – GabLeRoux Sep 5 '14 at 15:37
  • 1
    So far so good for me, after applying the change yesterday. – Bill Karwin Sep 5 '14 at 16:29
  • There's an answer on the issue page three hours ago saying it is working fine with Chrome Canary on 64bit Beta Channel with Hardware Acceleration still activated. I will try this too this weekend. – GabLeRoux Sep 5 '14 at 17:08
  • 1
    Interresting post on the issue page, the guy left a picture of its gpu usage using about:gpu url in chrome and hardware acceleration seems to be the problem indeed. After using firefox for a while, I had the issue again when watching videos on youtube too so that's not really a browser issue, but more like a GPU-accelerated graphics as you mentionned. – GabLeRoux Oct 1 '14 at 23:48
  • 1
    I've been running with this setting for a few weeks, and I can report I have not noticed any more weird video glitches, nor any kernel panics or reboots. – Bill Karwin Oct 2 '14 at 0:02
1

It may the same kind of problem (and fixed by the same solution) I had around mid 2012 with my mid 2010 17" MacBookPro which has the NVIDIA GeForce GT 330M discrete graphics card.

The problem is described here, along with a command that seemed to fix the issue: Interference on external VGA monitor (intermittent ripple) only when booted into MacOS X but OK on Windows Bootcamp, why? and how to fix?

Since upgrading to Yosemite on my mid 2010 MacBookPro, the problem has come back just recently. So I have repeated the solution, assuming that the upgrade to Yosemite had undone the setting.

I'll let you know how it goes with re-applying the solution. I hope it works for you.

1

Some have reported that gfxCardStatus fixes the problem to select only one card and disable switching.

fxCardStatus is an unobtrusive menu bar app for OS X that allows MacBook Pro users to see which apps are affecting their battery life by using the more power-hungry graphics.

  • Thanks for sharing this, I installed the utility, used dedicated graphic card only for the whole day and haven't seen the glitch again. Very interesting tool :) – GabLeRoux Oct 22 '15 at 19:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .