3

I have a MacBook Pro (Early 2011, MacBookPro8,2) which I cannot reboot, otherwise I have to reinstall Mavericks every time. Sleep mode works, luckily, but sometimes I need to reboot.

In April my HDD started to fail. I have noticed general slowness and the drive finally failed, I decided to install a SSD, and I choose a Samsung 840 EVO 500GB, which seemed to have good reviews.

The installation went fine and the drive worked perfectly, but since then, from time to time, but lately almost every time, I cannot reboot the machine. It stays stuck in the Apple logo with the spinner under it.

At this point I can access the recovery partition, the Apple Hardware Test, the single user command line mode. I tried once to boot from the Time Machine drive, but either it was very slow (and I was very impatient) or it didn’t work.

Following this http://support.apple.com/kb/ts2570 the Safe Mode (Shift) doesn’t work (it does the progress bar until one third, then the spinning wheel forever). Verbose Safe Mode (Shift+Cmd+V) shows the output until just mounting the hard drive (or just before mounting). Single user mode (Cmd+S) gives me a prompt, I can do fsck (no problems), I can mount the drive, I can modify files, but as soon as I type exit it just get stuck again.

The first time this happen I think I remember being able to reboot by doing a NVRAM reset, but that doesn’t work anymore. Another time it happened, I opened the laptop again and removed and re-attached the SDD, which seemed to work, but again, that doesn’t work anymore. The only thing that works is reinstalling from the Recovery partition (which is 30 minutes of downloading and 40 minutes of reinstalling).

I found this thread on Apple forums https://discussions.apple.com/thread/5413626 which describes a similar situation to mine. It seems that even if the controller claims SATA 6Gbps, the cable might not be fully prepared for it. It also seems that there was a EFI update to fix some problems with SATA drives (http://support.apple.com/kb/DL1450), which I must have installed back then.

Obviously changing the cable seems like an option, but I would like to know if someone knows a way to force the driver/EFI/whatever to force a slower link speed negotiation. Currently I have 6Gbps, but I will like to see if I can boot with a capped 3Gbps.

From other posts I have found people wanting to increase the speed, but I want just the opposite. Maybe it will fix my problem, and I can live with a lower speed.

More information from the System Profile:

Model name: MacBook Pro
Model identifier:   MacBookPro8,2
Boot ROM version:   MBP81.0047.B27
SMC version:    1.69f4

Intel 6 Series Chipset:
  Manufacturer: Intel
  Product:  6 Series Chipset
  Link speed:   6 gigabits
  Negotiated link speed:    6 gigabits
  Physical connection:  SATA
  Description:  AHCI Version 1.30 Supported
  • strange situation. i don't think it's the cable. fwiw, i had two people who upgraded their hard drive actually maim the cable in the process. it would partially work for a bit, but always fail. have you tried doing a diskscan or a zero-out of the internal drive? – neuralstatic Sep 19 '14 at 23:48
  • The disk repairs (and the permission repairs) normally find something, but nothing that seems too serious. Seems that everythin can be repaired from information in other points of the SSD. I haven’t tried to zero the drive completely, though, normally I install over the old installation. – yonosoytu Sep 21 '14 at 5:06
  • if it's doing a "successful" repair every time you run it, that's not good at all. i'd take that drive out and test in another machine or external case. also put a known good drive in the laptop and see how that behaves. has to be the drive or the cable, right? – neuralstatic Sep 22 '14 at 16:02
  • Right now I don’t have a external case available, but I will try to get one and try what you propose. Thanks! – yonosoytu Sep 23 '14 at 16:49
1

Have you tried to change the SATA cable?

Also have a look to the kernel logs inside the /var/log/system.log with the command:

grep kern /var/log/system.log -a2
  • After installing Yosemite I never had the problem again. Recently the laptop was repaired because the graphic card stopped working, so the cable might not be the same anymore. – yonosoytu Oct 17 '15 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .