1

I've been experiencing this since I got my new MacBook...

At my job, we work I'm a Microsoft environment. Our servers use SMB3. Our IT deptartment also doesn't officially support Macs. We also use network/domain user accounts. No local accounts. Therefore, we also mapped my domain drive to the Mac. I have my network drive connect on login and save my files and work directly from that location.

Here's my problem; When I try to save a file from an app, it keeps saying I don't have permission to write in this location. Then the auto-save OS X feature starts saying it can't auto save because the location can't be found. What's crazy is that I check the permissions in the "Get Info" window and I have Read & Write access. I also obviously have access o the location if I'm looking at it in Finder. I can make new folders and files too. I just can't save them?? IT has triple checked my permissions and it should be fine! So weird. Mac should be supporting SMB too. Sigh...

Screenshot of the error in Sketch app:

Screenshot in Sketch

Thanks for any help!

MacBook Pro with Retina display, OS X Mavericks (10.9.4), Using SMB3 Windows share

  • 1
    When you connected the drive, did you connect as "username" & "password" or "domain\username" & "password". I am not added to the domain but my employer does use AD or Domain services but that was required to make my MBP write to the network drives. – Bradford Benn Aug 6 '14 at 21:14
  • We've tried both. Still can't save that specific file. Maybe I'll try making a new file and see if the same thing happens eventually. There are quite a few possibilities we're exploring – jaminroe Aug 7 '14 at 0:56
  • We've tried everything now. It doesn't even like AFP. It must be something with our sever setup... And they don't want to use third-party open source stuff. Looks like we're just going to get a company Time Capsule and connect it to the network. – jaminroe Aug 17 '14 at 7:15

You must log in to answer this question.

Browse other questions tagged .