5

I homeschool my daughter and she takes several complex online classes. The teachers want me to be able to listen in and also be able to talk from time to time. I tried going without a mic, but there is way too much background noise for the listener. Recently, I purchased two Turtle Beach Ear Force PLa Gaming Headsets.

While they each work great individually we can't use them at the same time because, the Macbook makes you select a specific USB port. Is there some sort of USB splitter out there that would allow us to both plug into one USB port? When we just had to worry about headphones and not a microphone, we used a Belkin F8V234AMOB 6-Inch Audio Y Cable. My hope is to find something similar for USB ports, but I'm open to other suggestions.

Thanks in advance for any and all advice!

7

You don't need special hardware for this. Plug in both headphones, then open Audio Midi setup from /Applications/Utilities. Click the plus in the lower left corner and choose "Create Multi-Output Device." Check the checkboxes beside both headphones in the new panel on the right. If you want to rename it, you can double click the new entry in the list on the left and give it a name like "Both headphones."

Now you can choose the Multi-Output Device as the audio output in System Preferences → Sound. (You can also easily change the output by holding the Option key and clicking the volume menu.)

  • Jay - thank you so much for replying! I'm in the Audio Midi Setup and clicked the plus, but only the one headset is showing - though I have each plugged into their own USB ports. For some reason it is not recognizing anything in the second port. There are only boxes for the one Turtle Beach headset, AirPlay and Built-in Output. Am I missing something? – Teach1Mom Aug 6 '14 at 22:11
  • I might also need to mention that she has a Macbook PRO. – Teach1Mom Aug 6 '14 at 22:22
  • 1
    Can you take a screenshot of the Audio MIDI setup window and post it here? If you don't know how, see "Capture a specific window" here: support.apple.com/kb/HT5775 – Jay Thompson Aug 6 '14 at 23:47
0

If you have two headsets of the same name (shows up as same name under audio settings), then it won't show you two devices under Audio Midi Setup as shown above...

"One big problem with multiple USB headsets on OSX. If you are using identical USB headsets with the same name, only one will show up in the sound panel. I believe this is a bug, because past OSX versions allowed me to see multiple USB headsets with the same name. However in 10.5.8 and in Snow Leopard, multiple headsets with the same device name no longer appear. It's a real pain for me, because I can only use one of my favorite headset on my Mac."

0

The easiest way to ensure two devices appear in the macs audio system, is to use two different models of headset.

I believe that a USB device can have some sort of ID number to allow the Mac to tell them apart, but many devices don’t set this up. This is true of the Yeti microphone. The manufacturer can reprogram that mic to have a different ID number on request, which solves the problem.

  • No to this! You can aggregate input devices under macOS that allow you to use multiple mics of any/same manufacturer simultaneously. See: apple.stackexchange.com/a/266554/119271 – Allan Jun 21 '18 at 11:11
  • This is not correct, as the Mac cannot tell them apart unless the device IDs are different. Therefore only one device appears in the aggregator. apple.stackexchange.com/questions/169335/… Just because SOME manufacturers use different device IDs does not mean they ALL do. – Peter Johnson Jun 21 '18 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .