3

OSX 10.8.5

I am using lastPass and have the appleID in there so I can copy and paste whenever needed.

Sometimes when I am told I have an upgrade I am asked to sign in to the app store. Annoying but ok. So I have generated a quite safe password - why am I not able to paste that into the password field? Any setting I can change? (I obscured the appleID in the picture below)

enter image description here

  • I might be missing something here. But are you ever allowed to paste a password into an OSX password field? – CousinCocaine Aug 14 '14 at 14:35
  • Possibly not which is why I am looking for workarounds – mplungjan Aug 14 '14 at 16:01
  • Applescript could do some typing I guess. No clue how. – CousinCocaine Aug 14 '14 at 16:23
  • Learned some applescript today. Let me know if it worked. Good luck – CousinCocaine Aug 19 '14 at 16:55
4
+50

AppleScript

So, as I wrote in the comments, you can do this with AppleScript. Here I show how to create a service that types your clipboard using 'keystrokes'.

First create an automator 'Service' project and add a 'Run AppleScript' module. Enter the following script.

set clipboardText to (the clipboard as text)
set theCharacters to characters of clipboardText
repeat with char in theCharacters
    tell application "System Events"
        keystroke char
    end tell
end repeat

return input

Run applescript in automator

Now you can find this 'Service' in your 'Service' menu.

service menu

You can also create a keyboard shortcut (for example ctrlshiftv) in your System Preferences [Keyboard -> Shortcuts -> Services]. Now you can 'type' your clipboard anywhere when pressing ctrlshift.

keyboard shortcut services

4

You can use Keyboard Maestro with a macro such as this which takes the current clipboard and inserts its contents by typing it rather than pasting, allowing the clipboard to be entered into fields where pasting is forbidden.

        

Also, for what it's worth, OS X 10.10 Yosemite does let you paste into the aforementioned field and I believe so does 10.9 Mavericks.

  • Any free solution? My iMac is too old to upgrade – mplungjan Aug 14 '14 at 16:07
0

One possibility - right click & select Paste from the drop menu.

Works for several 'awkward to paste to' destinations.

0

Yosemite (possibly even Mavericks) solved the issue

  • 1
    There are still some fields you cannot paste to, unfortunately, for which right-click/paste seems to work - though I'm glad you got your issue solved :) – Tetsujin Dec 20 '14 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .