2

So I was watching some great BBC documentaries on YouTube last night, and before I fell asleep, I plugged in my Macbook (early 2013, 13") and set it on my nightstand.

When I got up today, I was unable to use the trackpad at all. Keyboard works just fine, but the trackpad does absolutely nothing. No clicks, no movement, no response.

I restarted, checked for updates, and did plenty of Google searching, but couldn't find anyone with a similar problem. I've tried safemode and my copy of Windows 8, and the trackpad worked with none.

My first instinct is hardware failure, it just seems odd for it to happen overnight while charging. I haven't unscrewed anything, but there's no indication of battery expansion or any external damage.

I bought it literally a year ago last week, so the warranty just expired. I can use an external mouse just fine, so it's not totally unusable (and I've made sure it wasn't the mouse causing problems, because I've fell victim to that before).

So, for clarification, this isn't the late-2013 model where there were known issues with the trackpad. It is early 2013, and it claims it has the latest the software update (however it's been bugging me for a couple weeks to update, which I haven't, and now it says there are no new updates, so this may or may not be relevant).

As far as I can tell, OS X isn't reporting issues with the trackpad, and Windows' Device Manager claims things are working fine. But absolutely no trackpad input works, and from my few hours of searching, nobody else with my model is reporting the same issue.

Anyways, any troubleshooting tips are greatly appreciated -- as well as potential advice for a possible part replacement.

Thanks a lot in advance.

  • Okay, so I came home after work today and opened the laptop from sleep... neither the keyboard or the trackpad were working. I held down the power button, opened the boot menu, touched the trackpad and the cursor magically appeared. After a reboot both keyboard and trackpad are working just fine. Absolutely no idea what caused it. But if anyone ever happens to run into the same issue... I guess leave it on sleep for a few hours, restart it into the boot menu (hold option/alt on startup) and check if the cursor works. I doubt all those steps are necessary, but something brought it back. – Schmal Aug 5 '14 at 0:34
3

Before you do anything hastily, try resetting your NVRAM: https://support.apple.com/en-us/HT204063

This will clear several hardware-related settings and may resolve your situation.

If not, try creating a bootable installer (https://support.apple.com/en-us/HT201372), boot from it and check if your trackpad works there. If it does, backup and reinstall your OS.

The alternative would be to open up the device and check if the trackpad connection is properly attached. Sometimes (although very rarely) the plug can become loose, likely due to radical temperature changes. You should only attempt this if you're comfortable with electronics repair and following a guide on a site like iFixIt. They also have parts for self-repair.

If the latter doesn't help, sometimes disconnecting the battery and reconnecting it works, as this will clear any battery-buffered settings remaining.

In case all else fails, I suggest purchasing a replacement part through iFixIt and following a guide to exchange the trackpad – if you're at all open to self-repair. Having it exchanged by a shop is always going by to be vastly more expensive. The upside being that they're usually required to provide a certain warranty period for repairs. This is not a complicated repair, so you may want to try it yourself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .