2

I just bought a new mac. I've been using it a couple of days, and today I find that under "Apps using significant energy" there is a listing com.apple.preferences.users.remoteservice.

What is it ? Why is it using significant energy ? Should I kill it ?

6

Some System Preference panes in Mavericks are built in a way to separate certain tasks into XPC processes.

The idea is to break up a complex application into individual processes, each of which requires only the few entitlements necessary to perform a specific subset of the application's total capabilities.

com.apple.preferences.users.remoteservice is one of these XPC processes. If you locate the process in Activity Monitor you should be able to tell which preference pane launched the process by the icon. In the screenshot below the process has the Users & Groups icon indicating that it belongs to the Users & Groups preference pane.

I'd check first to figure out which set of preferences it belongs to and make a judgement call on whether it makes sense that it is still running, but if one of these processes is using a significant amount of energy (and is still running once System Preferences is closed) I'd assume something has gone wrong and kill it.

Something you could do to attempt to understand what this process is doing is to open the Console application on your Mac and enter "remoteservice" in the filter box in the top-right corner. I'm assuming if the process is using a significant amount of energy then it is struggling to do something and will have written quite a few errors to the system log about what it is trying to do.

Activity Monitor showing XPC process

  • I can't close my system preferences window, because users & groups is deleting a user account. This has gone on for more than 24 hours, and the user account was a temporary account I created to setup my mac before I could migrate with time machine. I guess this must be it. – Kaizer Sozay Aug 3 '14 at 1:49
0

I don't know if it would be this straightforward for every situation, but I was having the same issue with this process using up too much memory.

What worked was switching the Systems Preferences from Network (the window open at the time) back to the main "Show All" window. Instantly, the process went away! Worked for me, anyway.

-1

its working ! Fixed to problem .

sudo launchctl unload /System/Library/LaunchDaemons/org.cups.cupsd.plist

  • How does unloading the cups printing daemon fix a problem with com.apple.preferences.users.remoteservice? – Alistair McMillan Dec 6 '16 at 19:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .