0

I have got 5 scripts listed in ~/Library/Address Book Plug-Ins/

  1. SkypeABDialer.bundle
  2. SkypeABSMS.bundle
  3. TelephoneAddressBookPhonePlugIn.bundle
  4. TelephoneAddressBookSIPAddressPlugIn.bundle
  5. Dial with Snom VoIP phone.scpt

Since the OS upgrade from 10.7 (Lion) to 10.9 (Mavericks) the .bundle plug-ins are still available within the "Contacts" application, however the AppleScript (.scpt) version is no longer listed at the former entry points.

How to fix this?

0

1. The launch services database is screwed up

This Contacts.app launch services problem/issue might appear again after each Mac OS X update, like the 10.9.2 combo updater according to http://web.archiveorange.com/archive/v/2NbVio0gzU3nWMhAxfsk

1a. Command line fix

$ /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -all l,s,u

In case of error messages like no such file or directory you can find the location of your lsregister with the command $ locate lsregister.

1b. OnyX fix

Or, you can run the OnyX application (version 2.8.7), go to tab "Automation".

Disable each check mark, except for section "Rebuilding", and make sure that item "LaunchServices" is checked.

Finally hit the [ Execute ] button.

2. Move to new folder

You need to move your Address Book Plug-In AppleScript(s) from the old

~/Library/Address Book Plug-Ins/
/Library/Address Book Plug-Ins/

to a new location:

~/Library/Application Scripts/com.apple.AddressBook/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .