I noticed that the Little Snitch's Research Assistant told me that the signature for Safari was invalid so i ran codesign to check and in fact i got this:

codesign -vvvv /Applications/Safari.app/
--validated:/Applications/Safari.app/Contents/MacOS/SafariForWebKitDevelopment
/Applications/Safari.app/: a sealed resource is missing or invalid
file modified: /Applications/Safari.app/Contents/Resources/English.lproj/InfoPlist.strings
file modified: /Applications/Safari.app/Contents/Resources/English.lproj/ServicesMenu.strings

Is this dangerous? I found out that this issue could be related to 1Password: https://discussions.agilebits.com/discussion/14419/safari-plugin-unverified

I have 1Password installed but the plugin works, so can someone explain this? Should i worry about?

EDIT: find another one: Safari seems to be modified

  • FWIW I have 1Password installed and Safari passes codesign – grg Jul 31 '14 at 14:46
  • Do you have the browser extension installed? What version of Safari and OSX? – Matteo Jul 31 '14 at 14:47
  • 7.0.5 on 10.9.4 (and 8.0 10538.46 on 10.10 DP4 14A298i). I have the extension installed on both machines. – grg Jul 31 '14 at 14:49
  • Ok, thank you for the fast reply, what do you think of my modified files? – Matteo Jul 31 '14 at 14:51
  • Perhaps you could upload them somewhere for comparison? – grg Jul 31 '14 at 14:54
up vote 1 down vote accepted

I don't think this is dangerous. I don't think you need to worry about it.

The affected files are just pairs of strings and the translated version for a particular language. The InfoPlist.strings file contains the file descriptions that appear in the Finder (and other places I assume) for the Document Types that Safari supports, for example "HTML document" and "CSS style sheet". The ServicesMenu.strings contains a similar short list of the Services provided by Safari, for example "Add to Reading List". The two files that are being flagged as modified are a bit boring as they are providing English translations for strings that are already in English. If you check the same files in another language folder within the Safari bundle, like for example French the concept is clearer.

<key>Web internet location</key>
<string>Adresse Internet du Web</string>
<key>Web site URL</key>
<string>Adresse URL du site web</string>
<key>Web site location</key>
<string>Adresse du site web</string>
<key>Windows icon image</key>
<string>Fenêtres icône image</string>

Within the thread discussing 1Password it doesn't appear that the modification was caused by 1Password. In fact it was initially suspected to be the reverse, the discussion in that thread was about whether the modifications were causing a problem with 1Password because someone was having trouble running it. In the end it turned out that the problem with 1Password was caused by Sophos. The modified Safari files had nothing to do with it.

For what it's worth I get the same errors when I run codesign against Safari on both my Macs. I tried reinstalling the latest OS X update (which includes Safari 7.0.5) but that made no difference. Even tried repairing permissions (which funnily enough did make one correction to a file in the Safari bundle) but unfortunately didn't resolve this issue.

Unless you have a problem running Safari or running extensions within Safari, I wouldn't worry about this.

  • Ok, i'll trust you. I also thought to reinstall the 10.9.4 update but if you say that didn't solved i'll leave it as it is. – Matteo Aug 1 '14 at 6:50

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.