1

I have my Google Contacts synched with my phone. I see all my contacts except the one that I need. I can go to https://www.google.com/contacts/#contact/18f963d78b764fd6 and see the contact in my account, but it is not showing up in my phone! I killed the phone app, turned off Google Accounts then back on, changed from Fetch to Manual then back, searched by name (both first and last), but no luck.

  • I had to add the contact to My Contacts. It would show up in my Google Account, but for some reason it was not part of 'My Contacts' category, and that seems to matter. It was listed under 'Other Contacts'. – Chloe Aug 8 '14 at 7:20
1

I've needed to goto my Google Contacts and add the person to the built-in "My Contacts" group. I haven't found the "My Contacts" option in the preview of Google's updated (for 2015) Contacts preview.

Google Support: Sync contacts with your phone

  • 1
    Wow you just copied me. – Chloe Apr 10 '15 at 3:33
  • Sorry, I didn't see that until just now. :P – somehume Jun 12 '15 at 20:25
0

Well, I am not entirely sure why a specific Google contacts will not show up on your iPhone, however, here's a workaround so you can make the son of a gun appear on the iPhone and in your Google account at the same time (the end result is the same as to what you want to achieve).

  1. On your iPhone go to Settings > Mail, Contacts, Calendars and under Contacts, make sure that the default account is set to Gootle

  2. Now create a new contact and manually add the same data as the one appearing for the Google contact in question > Save that contacts on the iPhone

  3. Delete the already-existing contacts from your Google account and let the newly-created duplicate stay

At the end, you have the contact appear under both your iPhone and Google account and be synced.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .