I used to have a 2nd generation iPod Touch, and had it connected to my email account at work (Exchange 2003). The iPod got push email as expected, and would often ping before Outlook (2010) would on my PC. I have since upgraded to a Verizon iPhone 4, and it does not get push email, or anything else from Exchange. I've deleted and re-added the account on the phone, and have verified that the delivery setting under Settings is set to Push. If I open the Mail app, then it gets email just fine. It won't even fetch it on its own; I have the interval set to 15 minutes, but I've never seen it receive email without the Mail app open.

Is anyone else experiencing this? Is it a bug introduced in the Verizon iPhone's branch of iOS?

I'm currently running iOS 4.2.8 on it.

UPDATE: I got some logs off of the device, and have found this error a few times:

(date and time) unknown dataaccessd[47] : EAS|connection died with error Error Domain=NSURLErrorDomain Code=-1004 "Could not connect to the server." UserInfo=xxxxxx {NSErrorFailingURLStringKey=https://x.x.x.x/Microsoft-Server-ActiveSync?User=xxxxxx&DeviceId=xxxxxxx&DeviceType=iPhone&Cmd=Ping, NSErrorFailingURLKey=https://x.x.x.x/Microsoft-Server-ActiveSync?User=xxxx&DeviceId=xxxxx&DeviceType=iPhone&Cmd=Ping, NSLocalizedDescription=Could not connect to the server., NSUnderlyingError=0x2f17f80 "Could not connect to the server."} 0x2f2cf20

In the links in the answer posted by berberich, Ping is discussed as a command that the device issues to the server in the process of negotiating the push (if I understand correctly).

2 Answers 2


I have a Verizon iPhone 4, and while I'm not using it with an actual Exchange server, I have several Gmail and Google Apps accounts setup as Exchange accounts that push emails to me without issue.

I would try two things if I were you:

  1. Setup a Google account on your iPhone as an Exchange account if you have't already, and see if those emails get pushed to you. If so, you can confidentially narrow the issue down to your specific Exchange server at work.
  2. Talk to your IT department at work and see if they have any errors logged related to ActiveSync. They might be able to determine if this problem is server-wide, or specific to your account.

Based on what I've read, this could be an issue related to your Exchange 2003 server at work. This Microsoft TechNet discussion is marked "solved" with an answer that links to an Exchange Team blog post titled "Direct Push is just a heartbeat away" that provides technical details for Direct Push/ActiveSync.

  • I have both MobileMe and Gmail set up on the device already. Gmail is set up as an Exchange account. Both of them get push email notifications just fine. I looked at your links, found some debug info in device logs, and updated the question. Commented May 13, 2011 at 20:01

I figured it out. I had the account set up to point to the internal IP address for our mail server, which obviously only works when I'm on wifi in the office or I have a vpn connection from outside. We have external exchange webmail access to our email, so I tried setting the mail server setting on the phone to that server name (mail.mycompany.com). It worked like a charm. My guess is that the phone drops off of wifi while asleep to preserve battery life. The iPod Touch does not because that's its internet connection, which it needs for push notifications to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .