2

I cannot input user account in English without changing input mode when to type user account at login dialog box. I have to change input mode to US every time when I boot mac.

Settings:

  1. Region is english
  2. Top priority input mode is English(US). Next one is Japanese.
  3. I setup for the login dialog box to type use account name and password for when its login.

Keyboard

Language Region

Environment:
Input modes: hiragana(Kotoeri)
Input source: US, Kotoeri
Keyboard: Japanese

Do you know how to enable English mode as default without changing input the mode?

  • Are you talking about the keyboard, switching from Japanese to English ? – Ruskes Jul 28 '14 at 8:13
  • No, would like to use English as input mode. – user3171796 Jul 28 '14 at 8:14
  • What is input mode ? the keyboard? – Ruskes Jul 28 '14 at 8:16
  • I use kotoeri. I remember that I did not need to change input mode every time before. How come, I have to change input mode every time. – user3171796 Jul 28 '14 at 8:20
  • Exactly what are you doing to "change input mode"? – Tom Gewecke Jul 28 '14 at 11:50
1

Check "Romaji" option for Kotoeri and remove "US" completely as it becomes useless with Kotoeri. This way you will have roman letters input just like with "US" keyboard.

If you have Japanese keyboard, use 英数 key to switch to Romaji input and かな key to switch to Kana input. If you have non-Japanese keyboard, it is possible whether to change input sources using hotkeys as displayed in Kotoeri preferences or to map Caps Lock key to switch input sources as many people do.

  • Thank you for your information. But I would like to use us and Kotoeri due to unrecognizable naming "Romaji" which is well known as Japanese input mode in Japan computer environment. So, I would like to use US and Kotoeri. – user3171796 Jul 31 '14 at 4:57
  • Then just keep US without removing + check "Romaji" input for Kotoeri to avoid switching it to Kana automatically. In fact it really depends what kind of keyboard do you use. Do you use Japanese layout or US/European layout? – Rilakkuma Jul 31 '14 at 5:00
  • I use Japanese keyboard, US, Kotoeri with Hiragana only. By the way, Did you read my question? I've mentioned on this post. please kindly check – user3171796 Jul 31 '14 at 6:05
  • From what I understand, you are trying to have Windows-like way - two keyboards, one for English input (US), another for Japanese input (Kotoeri). Unfortunately this does not work well on Mac. I've tried this too some time ago and went to using 英数 and かな keys for switching between English and Japanese input. There is little confusing setting too - "Romaji" actually means English input, while "Typing method: Romaji" shows your kana input method. Kotoeri falls into Romaji input by default so it is same as US keyboard, just name is different. So, the problem is naming only, i guess? – Rilakkuma Jul 31 '14 at 9:42
  • Thank you for your respond. I will try to use and escalate this. – user3171796 Aug 2 '14 at 20:40
1

Open sys pref and then Keyboard.

Make sure to DISABLE (uncheck) the Automatic switch to Document Input source.

keyboard

Set the order of languages to English at the top.

If done correctly, it will say "Primary" in the Language and Regions:

Primary

  • Thank you for the information. But it did not work. – user3171796 Jul 28 '14 at 10:08
  • please explain what did not work? with this setting you should always have English as primary input language. – Ruskes Jul 28 '14 at 10:35
  • not enough information that I mention so I add – user3171796 Jul 29 '14 at 11:05
  • @user3171796 There is no "japanese" on the input sources list. Do you mean Kotoeri? Are the boxes for Hiragana and Romaji checked, so that Hirgana and Romaji appear in the "flag" menu at the top right of the screen? Do you want Romaji to be the default for login? – Tom Gewecke Jul 29 '14 at 12:20
  • I use Hiragana only for Kotoeri. Please take a look my question which I updated with attachments – user3171796 Jul 31 '14 at 2:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .