26

The image below is the header that appears when I open Terminal.app. As you can see, only one tab is open, but a tab bar still shows (just has one tab that says "bash"). How can I prevent the tab bar from showing unless there are >= 2 tabs? It was working correctly until recently but I can't figure out what changed or how to fix.

enter image description here

41

Click "View" / "Hide Tab Bar" and the tab bar will go away and come back only when there is more than one tab open.

3
  • I will not have access to the computer that had this problem until Friday, but if this works then I will accept.
    – Kvass
    Jul 28 '14 at 14:44
  • 4
    I scrubbed all over the preferences panel looking for this... never occurred to me to look for a top-level menu.
    – bronson
    Oct 17 '16 at 20:13
  • After upgrading macOS, this tab preference reset, so I scoured preferences and didn't find it... they really need to move this to preferences -> General (or put it in both places). It acts like a preference because if you change it, it affects other windows.
    – Kelvin
    Aug 6 '19 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .