0

I want to disable the the [Number] shortcuts in Safari to prevent losing content when I accidentally click it.

I’ve followed the method in this answer. I’ve changed the shortcut for Apple to   F10 But whenever I press 1 in Safari, it still opens the Apple homepage.

I make sure that Safari » Bookmarks » Apple menu item is labeled with F10, not 1.

I’m using OS X 10.9.4 and Safari 7.0.5

  • The answer I gave in the link works for me to disable the old shortcut in 10.9.2; what version of Mavericks are you using? – grg Jul 27 '14 at 13:20
  • @GeorgeGarside, oh, I missunderstood your answer. Theoretically it should work for me. But practically... I changed the shortcut for Apple to AltCmdShiftF10, and I see it in Safari\Bookmarks menu, but when I press Cmd+1 Apple page opens as usually. I have OSX10.9.4. Safari 7.0.5. – klm123 Jul 27 '14 at 13:25
2

Using OS X 10.9.4 and Safari 7.0.5, I've replicated the results of your shortcut alteration attempt. It seems that adding the new shortcut doesn't replace the old one.

Removing everything from the Favorites Bar works for me. This is certainly not an ideal solution, but depending on how you assign value to the usefulness of the Favorites Bar and the importance of potentially lost content, this may be useful to you until a better solution is discovered.

Extra info and opinions:

  1. The problem persists after hiding a non-empty Favorites Bar
  2. I'm surprised that Apple doesn't list all keyboard shortcuts for their own applications in System Preferences
  • Omg. I removed everything from the Favorites Bar, but it is back now! Tried two times. I guess it is after reboot the Favarites bar is restored. – klm123 Aug 12 '14 at 18:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .