I'm trying to upgrade my Macbook pro late 2011's hard disk to an SSD from Corsair.
I have inserted the USB stick with the OSX Mavericks installer, and everything went great: I made a GUID single partition table, and then erased the disk as Mac OS X Journaled. Then I clicked Install OSX Mavericks and selected the SSD. After 13 minutes, the blue bar is complete, and on top, it says: 'Preparing to install. Your computer will restart automatically.'. Below the blue bar, it says 'About a second remaining'.
It's stuck on this state, with the mouse on the spinning wheel mode, for over a full hour. I'm really starting to worry.
I looked online and found a guy with a similar problem, but he only waited for half an hour. What should I do? Thanks!

  • Check the log! It's your friend.
    – Shane Hsu
    Commented Jul 25, 2014 at 14:54
  • 1
    Sometimes the auto restart gets stuck because of some app running. Use alt-cmd-esc to see what is running. Or simply manually (forcefully) restart.
    – Ruskes
    Commented Jul 25, 2014 at 15:11
  • 1
    Well, if it does stop to respond. You have no choice but to do it all over again it seems. Although use Dusk Utility to check for disk failure, for both source and destination, and put the log window up front when installing do you can see logs if something does happen again. (Remember to choose "Show All Log" and not just errors.)
    – Shane Hsu
    Commented Jul 25, 2014 at 15:12
  • 3
    Press ⌘L​​​​​​​
    – grg
    Commented Jul 25, 2014 at 17:02
  • 1
    I had the same problem. Installing new SSD on MBP mid-2010, El Capitan on a Flash Stick. Stuck in "about a second" for about a half-hour. Nothing going on in the install log at all. Then it suddenly re-booted and continued the installation.
    – Mark
    Commented Sep 10, 2017 at 1:38

11 Answers 11


The problem with the upgrade script is the timing only estimates how long it takes for Apple's software to install.

You can (and should) open the log file while upgrading/installing and press Command-3 to show all logs, not just the errors.

  • +L
  • +3

You can see that during this "about a second" it's really migrating user files and handling all the things you've brought to the Mac that isn't part of the base system.

Basically, let it run as long as you can stand - especially if the log file shows progress being made. If progress isn’t being made, consider connecting to the internet via a wired connection if possible or making sure the wireless network is operational before interrupting what looks to be a paused or stopped installation.

  • 5
    Just to note – I didn’t have much hope, since not only was the log file not showing any activity, but the computer’s hard drive was actually spun down. But after waiting an hour or two it moved past the “about a second” screen, rebooted, and completed the installation. 👍
    – Benji XVI
    Commented Jan 9, 2016 at 20:27

I was worried about the same, until it finally went through. I opened the log and it was getting a lot of errors, but while I was reading about this on another computer, it suddenly finished with a message that everything was copied and it automatically rebooted. I was performing a clean install of El Capitan on a new Samsung 850 EVO SSD on my MacBook Pro 13" mid 2012. I guess the key here is just to be patient.


I had the same one second remaining and the log said it was trying to verify the installer. I plugged in my ethernet cable and couple minutes later it finished.


I had this problem and realized it was because I was not connected to the internet. Connect to either WIFI or plug in an ethernet cable and the install will finish in a few mins.


I used a flash stick, erased the MacBook's drive, went ahead with the install, and I get this seemingly eternal wait while it says "about a second remaining" ... so it can't be migrating files or anything.

  • 2
    Actually - the "about a second remaining" is precisely when the installer is moving the files that it doesn't know about. i.e. It doesn't have a count of how many of your files it has to move, so it fails to give an accurate estimate. I've filed bugs with Apple, but they apparently think this is proper. Open the log file and show all details (Command L and Command 3) to see each file getting moved one by one... during the "one second left" phase.
    – bmike
    Commented Oct 1, 2015 at 18:49

I had the same issue on a Mid-2011 iMac 27 inch. New Hybrid HDD. I tried to install El Capitan from a USB drive and it would get stuck at "1 second remaining" with an error in the log. I rebooted and held down command-r. This loaded the internet restore, and let me install OS X Lion. Once Lion installed I was able to use the app store to install El Capitan.


Just wait even if you erased the drive completely for installing it takes several minutes not seconds to prepare the system for installation I had the same issue it cleared itself out opening the log helps to see the process isn't stuck you could actually see it working


I did a clean install on a brand new SSD and had the same problem. To resolve this, when it says "about a second remaining" just leave it and it will finish eventually (mine took almost 4 hours). Worst thing you can do is keep trying over and over again as you'll just be wasting your time. It will finish the installation, even if it has errors :)


I had the same issue. The first time I thought it was frozen, after waiting about 35 mins, I shut it down and made a new attempt. This time I just waited for more than 14 minutes and the reboot worked fine. Just be patient. (Instaling El Capitan from a memory stick onto a new SSD Samsung EVO 850 hard drive with an iMac 21 mid-2011.)


I had this for about an hour, then noticed the WiFi symbol in the top right had disconnected from my network (greyed out). I reconnected to the same network I'd connected to when starting the installation, and it continued installing.


Had the same issue.

The installation can be sped up by deleting files stored in /usr/local/bin. (by rm -rf /usr/local/bin in Terminal app)

It went even faster for me by using a USB stick with OS X and erasing the disk before installation. For USB stick (need stick > 8GB) see: https://support.apple.com/kb/HT201372

After reboot press alt then select the USB stick, then select Utilities → Disk Utilities.
Here you can erase your disk (careful not to erase the stick!) and format it as Mac OS Extended (Journaled).
Now just continue the install process (5 minutes for me, after previous 8h+ aborted).

Worked with Yosemite 10.10.4 Beta

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .