3

Image Capture doesn't recognize iPhone 4S. I'm using OS X Mavericks and iPhone 4S 64 GB with latest iOS 7.1.2

iTunes detects the phone and can perform a backup. iPhoto and Image Capture do not see the phone at all.

I'm using an original Apple cable and the phone is not modded in any way.

  • I have the exact same situation — 64 GB iPhone 4S running iOS 7.1.2 and a Mac (Early 2009 17" MacBook Pro) running Mavericks. I have a small modification: Image Capture does see my iPhone at first, but in the middle of a transfer it errors out, disconnects from Image Capture, but stays connected to iTunes. iPhoto behaves identically to Image Capture, as well. – 75th Trombone Aug 12 '14 at 3:14
1

I had this problem (in Yosemite, iPhone 4S) and got it working. The solution is based on what appears to be a dependency that Image Capture has on iPhoto. In my case the issue was that upon upgrading the OS, my version of iPhoto was not compatible with it. I updated iPhoto to a compatible version, and now Image Capture again recognizes the phone. I hope this is helpful to someone with this issue.

1

If you have a lock screen password/code etc. then you first have to connect your iPhone to the iTunes on your computer. The two will then perform a handshake where you will unlock you phone and say Yes to a notification on your phone asking you whether or not to trust this computer.

As far as I'm aware, the issue that you were having is that Image Capture does not perform this required handshake, so the phone doesn't know to trust this computer until you connect it through iTunes. PS. You should only need to do this once, after that it should work without iTunes, but don't quote me on that.

As to why iExplore worked, I'm just guessing, but they've been known for finding really cool loop holes in iOS for years, so I wouldn't be surprised if this is just another sweet trick they found. Or most likely they just do the an iTunes-like handshake. ;)

  • 1
    Opening iTunes worked for me. After that Image Capture populated images off the iPhone. Thanks – Josh Newman May 14 '15 at 1:02
0

TL;DR: Use iExplorer by http://www.macroplant.com/iexplorer/.

I solved this by using a work around. Image capture would never work for two reasons. Each of them alone would have made it practically impossible but both conditions together only exacerbated the problem. 1) My phone had over 28,000 images. Even using a MacBook Pro maxed out it would not recognized the iPhone. 2) There were images downloaded form the internet that included different formats not created by the iPhone's camera.

After several hours of trying different things and scouring the internet I was not able to get it to work. I decided to plug in iExplorer (note: this is not an add for iExplorer and I'm not getting anything of posting this. I already had this program.) iExplorer lets you browse the images like a drive. As you can imagine it took a very long while to copy over 28k images to the computer. Heck, when it was done I rebooted the phone. I had to manually clean up the images. It took a long while. When I was done deleting the images manually, I rebooted the iPhone again and then zombie images (I'm not joking) started to show up and the iPhone said restoring even though it was not connected to any computer or internet connection. In total about 3,000 zombie images appeared on the iPhone. I moved those as well. After the clean up and took a couple of screenshots and images and the iPhone was recognized as normal. Hope this helps. - Adam

0

What fixed it for me was using an Apple usb-lighting connector. The cheaper cables purchased at Walgreen's or wherever would charge the device and work with iTunes but the device would NOT appear in Photos.app or Image Capture.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .