236

On Mac OS X Yosemite the green icon in every window:

enter image description here

is by default used to make the application full screen.

How do I make it work the same way as in previous versions of Mac OS X, i.e. to maximize the window?

  • 14
    I take it that you know option+click does return it to the previous behavior. But yes, this should be an option for the user. – Shane Hsu Jul 25 '14 at 15:04
  • 2
    What about the old option+click functionality? It used to do full screen without removing the menu bar and dock, etc. – CWSpear Oct 17 '14 at 16:14
  • 14
    you can now double click the title-bar to maximise and un-maximise :D – Jonathan Oct 17 '14 at 18:44
  • 5
    @Jonathan, true for windows that have a proxy icon, but not for, for example, Chrome. – Arjan Oct 19 '14 at 19:05
  • 7
    This is one of the most weird features of the yosemite, ever. – edigu Mar 20 '15 at 14:53
199

In order to maximize the window so that it fills the visible window content, use:

+ Click on green icon

In order to maximize the window both in width and height to the current desktop for applications like Google Chrome use:

+ + Click on green icon

You notice the change of behaviour of the button in the way it changes its content from two the arrows to a plus sign.

Another way to approach this problem is to ignore the button entirely and to install the open source app spectacle which offers the keyboard shortcut:

+ + F

It also has some other nice features, too.

  • 2
    I see no difference in behavior between Option+click vs. Option+Shift+Click. Apple Mail maximizes to screen size either way; Preview zooms based on the content either way. What is an example of an app that behaves the way you describe? – willkil Oct 22 '14 at 20:56
  • 5
    @willkil, Chrome is a good example of an app that needs Option+Shift+Click in order to maximize in both directions. – bassplayer7 Oct 22 '14 at 21:57
  • 1
    @bassplayer7 That makes sense about Chrome, since Shift+Click used to maximize Chrome in Mavericks. But Chrome was the only app I know of that did that. iTerm's behavior was (and is) opposite of Chrome -- left click maximized, Shift+Click (+Option now) resized the window to "match" content. I wish there was a standard way to always maximize a window on OSX, but I really don't think there's any such standard. I think Google just added the +Shift maximize feature to Chrome to compensate for OSX not having the feature. – willkil Oct 22 '14 at 22:47
  • 2
    unfortunatelly Safari does not know option + shift + click – János Jan 23 '15 at 11:34
  • 3
    Wow, would it have killed Apple to give us a tool tip here? For people obsessed with design and usability, hiding an oft-used feature behind its guaranteed-to-be-annoying-to-many-people replacement, and then providing no hint that it was still there, seems like a ball drop – Sean DeNigris Aug 24 '15 at 16:35
74

Zoom function can now be performed more easily — by double-clicking window title. You don't need to precisely aim at the small green button anymore, which I believe is the reason it has been converted into full screen button by default.

If you hold the shift key and double-click the window title Applications that use "smart zoom" will be forced to do full screen zoom. Smart zoom was a (much missed) OS X window behavior where, rather than fill all of an immense display, the window would enlarge based on its "needs". Apple removed smart zoom behavior form its own apps, but Chrome still does this.

So, in general, make the painful switch to working with the title bar and ignore the green button except for the rare times you truly want full screen. If you get 'smart zoom' and want to fill screen instead, repeat but hold shift key.

  • 15
    This is not true for all applications. Like it does not work in Chrome, Firefox and TextWrangler. – Arjan Oct 20 '14 at 20:15
  • 4
    @Arjan Those are temporary problems of applications with non-standard window designs that were made before Yosemite. They will be fixed soon. – hamstergene Oct 21 '14 at 8:48
  • 7
    This will also not work if you have "Double-click a window's title bar to minimize" in the System Preferences > Dock menu options. – Mike Kormendy Oct 27 '14 at 20:48
  • 4
    It also doesn't work with Xcode 6. Apple's own friggin' development tool. – davidf2281 Dec 24 '14 at 10:53
  • 2
    Ah, thanks for that @hamstergene. I still hate the new default behaviour though, and the fact that the new double-click to maximize interacts with the existing double-click to minimize is pretty horrid... – davidf2281 Dec 25 '14 at 10:01
12

Hold option and left click the green button to have it maximize but not go to full screen.

  • This only maximizes it to the full height, not the full height and width of the desktop minus the menubar (and minus dock if you turned dock hiding off). – Mike Kormendy Oct 27 '14 at 20:44
  • But, @Mike, this was the pre-Yosemite behavior, right? – Arjan Nov 29 '14 at 10:59
  • No, not entirely right. Unless "Double-click a window's title bar to minimize" in Settings -> Dock was enabled/disabled (can't remember which one now). – Mike Kormendy Dec 1 '14 at 0:43
9

Disable option "Double-click a window's title bar to minimize" in Settings -> Dock. Now you can use double click on the window's title to maximize it.

  • That is, if an application has been designed to respect this action. Some programs are designed to float as a window even though they have a regular looking title bar. – Mike Kormendy Oct 27 '14 at 20:51
  • Works for Chrome and Terminal. This is all I need. – Tony Baguette Nov 5 '15 at 3:55
7

@Wladimir Palant has a great solution, using BetterTouchTool to reassign the role of the green button. Works for me!

Note: @Wladimir's answer actually solves this question, not the one he posted in.

4

I've already posted in a similar topic - Check out the free"spectacle" that has a bunch of handy window management shortcuts.. Running that app adds cmd+option+F for true full screen with status bar.

PS. I really hate that instead of adding the "option" key for the current maximize to full screen behavior they just replaced the button that people used for years.

PPS. I tried double clicking windows, it does not work as expected, at best it somehow resizes the screen, so it's maximum height, but it does not fill the entire width of the screen. A chrome window with tabs ignores double clicks.

PPPS. Option+click does not work as expected either - it does the same thing as double clicking the window - the window resizes in vertical direction, but not in horizontal one. (I have two monitor system, and it does not fill either one of them).

  • Since we're venting, I really dislike the idea that people want a certain behavior only because that's what they're used to. It's very difficult for a human to understand whether they want a certain behavior because it's better or because that's what they're used to, so it's best to err on the side of the cognitive bias that makes us creatures of habit, otherwise you may end up inadvertently impeding progress. – zumalifeguard May 17 '15 at 16:06
  • 1
    Zuma, we've been using OS X for over ten years now. It's called muscle memory. It's highly destructive to force existing buttons to work differently. This should be a preference. It's my computer, not Apple's. – Foliovision May 31 '16 at 1:57
1

So, pre yosemite, holding "Shift + Left Click" would alternate between the current dimensions and what they'd be if you were to maximize the window to the fully available dimensions.

The "Option + Left Click" alternates between window sizes (the last and the full-height of the screen (less the dock). Also, regardless of where the page is focused, after using the option click, the focus reverts to the upper left of the page (fun-fact).

Another thing to note is if you have more than one window open the "option + left-click" will maximize the secondary window, and depending its current dimensions, adhere to the same scale as if you were to hold down the Option key when click-dragging the corner of the window to manually resize the frame (scales on a fixed ratio).

To answer your question try "Option + Left-click" and/or "Shift + Left-click". Then perhaps try them together ;)

You must log in to answer this question.

protected by grg Oct 29 '14 at 11:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .