0

I'm experimenting around with my computer and I realized that all the commands in the terminal that aren't bash builtins were stored in the /usr/bin. So I wanted to see (to confirm my realization) that they would not work in Terminal if they weren't there. So I copied bin to my desktop and deleted bin in usr. Sure enough, I was right. All the builtins still worked but things like 'say' didn't. Feeling content with myself for figuring out something about my computer, I promptly placed bin back in usr and check to see if 'say' was working to confirm no harm was done. It worked. Then some time later I need to use sudo for something and I get an error. I restarted my computer, hoping that would help. Now I can't even use Terminal anymore. When I boot it up it says:

Last login: Fri Jul 25 01:12:20 on console
login(529,0x7fff744b4310) malloc: *** error for object 0x7fcfa3600e20: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug

[Process completed]

Uh-oh, so how do I fix this? The only thing my non-educated brain can think of is a reinstall of OS X.

  • 1
    Create your own answer on this question. Then we see this question is answered. – CousinCocaine Jul 25 '14 at 7:54
  • 1
    Summary: try Disk Utility -> Repair Disk Permissions. Some permissions were messed up when you moved bin to your Desktop. – aglasser Jul 25 '14 at 13:55
  • Yeah I would've answered it myself, but I figured it out within 8 hours so I couldn't do it because I'm pretty new here. – Mason Jul 25 '14 at 21:59
1

I figured it out by searching it myself (sorry for not thinking of that first). You just go to the disk utility and click 'Repair Disk Permissions'.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .