0

I'm trying to install GTK+3 on my Mac OSX 10.9 system to run a pyGObject project I've been developing in Ubuntu. It runs perfectly on Ubuntu, so I wanted to test cross-platform compatibility. I'm following the directions on wiki.gnome.org.

I finished the part where I run the sh gtk-osx-build-setup.sh command. It loads everything perfectly (as far as I can tell). However, if I do a which jhbuild or try a command, I get an error:

EnvironmentError: MacOSX10.9.sdk not found
jhbuild: could not load config file 

Any suggestions on how to fix this and finish installing jhbuild? It seems like the instructions from their webpage are a little incomplete or perhaps I'm not adding to path correctly?

Questions:

  1. Which file do I put the path? Is it .bashrc or .bash_profile (neither have worked so far). Perhaps some other file is my bash profile script?

  2. What is the path to the jhbuild? In the example, it says alias jhbuild="PATH=gtk-prefix/bin:$PATH jhbuild", but I'm not actually sure what I should substitute in for gtk-prefix (not sure where the actual path is, since which jhbuild doesn't work).

  • It is ~/.bash_profile to edit the PATH for use in terminal see apple.stackexchange.com/a/119714/237 - we need to see what is in this file. The easiest way to install complex C programs is to use a package manager e.g. Macports, Homebrew – Mark Jul 24 '14 at 18:16
  • I would second Mark's suggestion though. Using Homebrew is a LOT less painful. – Alistair McMillan Jul 24 '14 at 18:47
  • I'm having the same problem with a CentOS 6.4 install and even though it's in the PATH in the .bashrc, it doesn't allow me to import gi in Python. A real pain, so far. It is resulting in lost time, so I'm using PyGtk with GTK+2 and it's working fine so far as a temporary solution. – Blairg23 Jul 26 '14 at 0:25
  • And I agree, Homebrew is the way to go. – Blairg23 Jul 26 '14 at 0:25
1

Forgive me if this is a silly question but do you have Xcode installed?

The OSX SDK should be installed on your system within the Xcode application bundle. You should be able to find it at /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/.

If Xcode isn't installed you can install it for free from here.

  • Xcode says it's installed and up to date. – Blairg23 Jul 26 '14 at 0:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .