4

I've tried every suggestion I could find on Apple forums. Deleted .plist files, removed message caches, reset passwords, coordinated sign on/offs between my iPhone and my Macs, reset iPhone and reinstalled Mavericks on my Macbook Air. All pointless exercises.

I suspect it all started because I jailbroke my iPhone using Pangu. It may or may not have been the culprit, but my problems started a couple of days after I did it. All my phone conversations went green and stopped synchronizing with Messages apps on my Macs. Trying to send a new message from Macs would result in either "Your message could not be sent" error with a warning icon next to it, or:

XXX is not registered with iMessage.

So I restored my iPhone to factory defaults using iTunes. That didn't help immediately, but in a day or two, my conversations with other iPhone users went blue. So I am happy that works.

So now I sacrificed my Macbook Air to try and make messages work on it. I reinstalled Mavericks several times, each time trying different approaches: not immediately signing into iCloud, not associating an iCloud profile with login profile, etc. Nothing helps. I launch Messages app, it asks me to sign in (and I do, successfully), and then nothing goes through.

Sending messages to myself also works inconsistently. Yesterday, whatever I sent to myself (using phone number) would appear delivered to the same window, but not on my phone. Today I get "... not registered with iMessage" error.

  • In Settings>Messages: the iMessage setting is turned on, right? And then, when you scroll down, the Send & Receive field lists your phone number, right? (just want to make sure) – Chris Mukherjee Jul 23 '14 at 14:30
  • Yes. iMessage works on the phone. Interestingly, in both configurations: when I have iCloud account associated, or without it. – Alex Polkhovsky Jul 23 '14 at 14:32
  • 1
    It seems you have the same problem as me apple.stackexchange.com/questions/135303/… :( – Matthieu Riegler Jul 23 '14 at 15:29
  • I launched Activity Monitor => Network. Messages app is all zeros. No traffic in or out. Firewall is off. iPhone on same network can send/receive messages. So maybe Messages somehow lost the server address? – Alex Polkhovsky Jul 24 '14 at 0:42
  • 1
    @CousinCocaine Please make an effort to read the description. I'll quote the relevant sentence for you anyway: Trying to send a new message from Macs would result in either "Your message could not be sent" error with a warning icon next to it, or "XXX is not registered with iMessage". – Alex Polkhovsky Jul 28 '14 at 14:19

12 Answers 12

3
+50

I had a similar problem, with the culprit being that iCloud got confused, and continued to send text messages as iMessages, so that my new phone (non-iphone) never got them.

Turns out, in order to turn off iMessages settings, you must disable iMessage EVERYWHERE. If you turn off iMessages on a phone, and leave it on your iPad, it won't reset (this was my issue).

So, I suggest you try this: iDevices (all of them): Settings>Messages. Turn off Messages. (on your iPhone, you can turn on sms message so at least you still get texts). On Macs, remove any accounts in iMessages by clicking '-' by them in the account preferences.

Make sure you have de-registered on ALL your devices. Give it an hour or so. Then create accounts on messages on the devices using your Apple ID. See if it works.

If this does not work, call AppleCare. I found that if you go to the AppleCare link in the website, it warns that it will charge you $$ per min for help if you don't have an AppleCare plan. Call the number anyway, agree to whatever. When I called, Apple did not charge me for the iMessages issue, as it is a known issue. (mine was slightly different, I will admit).

  • In additional of the steps recommended by @cmason, I suggest to only connect the iMessage to your Apple ID and skip the phone number altogether. – sayzlim Jul 29 '14 at 15:51
  • unfortunately @sayzlim, that is not possible with an iPhone, as it requires associating with the phone number, even before Apple ID. On iPad, iPod and Mac, this is possible. – cmason Jul 29 '14 at 19:29
  • Just tried it. Waited three hours. Logged into Messages on my MBAir, tried iMessaging my wife. Her name changed to red and an error popped up saying she is not registered with iMessage. – Alex Polkhovsky Jul 30 '14 at 16:51
  • I like cmason's answer.. Call Applecare. I wouldn't be surprised if it's an iCloud problem.. Ask them to for a case number in case the problem doesn't get fully resolved. With a case number, you can request second-level support. (engineers). – David DelMonte Aug 3 '14 at 4:57
  • I did call Apple Care. Paid my $19. Spent a few hours figuring out the issue. Calls back and forth. It does seem to be an issue with iCloud. They seem to have multiple registration profiles for my MBAir and iMac hanging around, while my iPhone has precisely two (one for Facetime and one for iMessage). They can't manually remove the extra registrations. I'm told the engineering team is working on a fix, which will most likely be server-side. Apparently, I am not the only one with this issue. – Alex Polkhovsky Aug 4 '14 at 15:12
2

I have had this happen on one of my Macbook pros. It turned out that the Macbook's serial number had been lost when after a hardware repair had been completed by a third party.

If you go to About this Mac and choose More info you should see your serial number, if it is missing that could be the problem.

enter image description here

  • Thank you. I do have serial number in place on both Macs. – Alex Polkhovsky Jul 28 '14 at 14:17
  • Okay, that eliminates something at least – Paul Gilfedder Jul 28 '14 at 14:18
1

I had a different problem with safari freezing when I swiped back a page. Resetting my PRAM fixed safari and also fixed the problem with Messages.

Shut down your Mac. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. Turn on your Mac. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound. Hold these keys until the computer restarts and you hear the startup sound for a second time. Release the keys. So give it a try it might work for you too.

  • PRAM reset fixed things for me too after I couldn't log in on my Mac, but it took a few tries of entering my password at the Messages login window for it to take. Super weird, thanks for your help. – Nick Oct 18 '15 at 23:41
1

The Problem was only for sending and receiving msg on my MacBookPro, To fix it I had to go on my iPhone: Setting, Messages, Transfert SMS, and then on my mac a code just appeard, I've enter this code on my iPhone and the problem was resolved :-)

1

I had a similar issue where Messages on my Mac Mini had been sending and receiving texts and then suddenly stopped.

Turns out I had to go to

Settings -> Messages -> Send & Receive -> Use Your Apple ID for iMessage

on my iPhone. After verifying my Apple ID password, it worked.

Hope this helps!

0

This might be a far shot but try removing and re-adding your credit card information in your apple ID.

  • Good idea, thank you. But it didn't help. – Alex Polkhovsky Jul 24 '14 at 0:39
0

I had the same issue, that iMessages didn't show up on my Mac - only on the iDevices.

The root cause was however, that iMessage was not active anymore on the iPhone, as pointed out by @chrismukherjee via In Settings > Messages the iMessage setting is turned on.

0

I have found that disabling and enabling FaceTime on both the iDevices and Macs can help solve iMessage problems.

0

I found a solution! Go to Messages > Preferences, select the account in question on the left side column; click the "Account Information" tab and tick the "enable this account" box opposite of the selected account. All works great now. Hope this helps...

0

Settings -> Messages -> toggle it off, then toggle it back on and tried signing in on my macbook again and it worked

0

On your iPhone, go to Settings > Messages...

Then turn off, and then on again, the iMessage toggle at top.

Now try again on your desktop. That worked for me.

-1

I had a similar problem. I believe this starts when you connect both you iOS device and your Mac to the same iMessages account. I never bothered to fix it on mine (I just stopped using it on my computer LOL).

But I actually think I know what will fix it though. You can make a new Apple ID account for your iCloud and messages (still keep the old one for iTunes and the App Store though).

When you sign in to the new account, any problems that you had with the old one should be gone – I'd expect. But I wouldn't recommend connecting both your computer and your phone until you're sure it works on one of them.

Hope this helps :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .