3

I have an Epson Stylus NX625 that my family had been using from several Macs and Macbooks until recently. Now when we attempt to print the Mac reports "Looking for printer" for several minutes followed by "Printer not connected." The printer reports no error (it thinks it is properly connected to WiFi.)

This problem started around the time I replaced my old Airport Extreme with a new 6th gen Airport Extreme (the tall one, with 802.11ac).

My Macs can still print properly if I connect the printer directly via USB (it is normally configured for wireless printing.)

I have updated the printer drivers and reset the printing system on each Mac.

I am stumped. Any ideas?

2

I had the same issue, had to turn off and on the printer to get it to print every time even if the jobs were only a few minutes apart. I was not thrilled about changing the 5GHz name as suggested above.

I resolved my issue by going into the Airport Utility on my iphone, go to Edit->Advanced->Add WPS Printer->With pin

Now my Epson Workforce 845 works as it should. I assume there is something in the router that treats a printer different than a general client and adding it as I did above solves it...at least it did for me.

1

I have dozens of clients using 6th generation Airport Extreme routers. Wifi printers connected to the Extreme (via wifi) sometimes half-drop (i.e., the computers still show connectivity to the printer but nothing prints); this happens to 3 or 4 of my clients about every 6 months. Power cycling their Extremes has been the effective and tolerable workaround for a long time now.

I think the AE needs power cycling about every 6 months, anyway, to fix other wifi-connection and speed glitches.

I dealt with Apple engineering on a totally different whacky wifi problem but my client stopped the troubleshooting because he didn't want to pay me for it anymore. That episode showed me, though, that there's definitely some strange wifi problems with the AE, which I still recommend and install more than any other router.

  • I've got my Apple networking gear on UPS so I've started doing monthly reboots whether they need it or not. I'll probably see if I can script the controlled restart rather than getting a power switch that I can program to reboot things periodically. – bmike Oct 13 '15 at 18:44
0

I just fixed the same problem. New AE with ac channel. The ac takes over the 5GHz channel and appears to be the problem. Open the Airport Utility, go to the wireless tab and pick Advanced. Check the box to rename the 5GHz and reset the AE. That forces the printer onto the 2.4GHz channel

  • UPDATE: it's wireless options, not advanced. I used iStumbler to id the problem. – BillRaynor Aug 2 '14 at 9:23
  • That worked! Nice sleuthing!! I also had to delete and re-add my printer in order for my Mac to start printing wirelessly again, but your solution worked like a charm. Thank you! – ckames Aug 4 '14 at 0:02
0

There's a new problem arising with wifi printing in that printers will only connect on the 2.4GHz band. This band is now congested in many homes in residential areas so the printer may work for a while but then loose connection and not be able to reconnect because there are no available wifi channels. I hope printer manufactures will quickly get 5GHz support for there printers in the mean time using a Ethernet cable to your router will work as long as your printer supports Ethernet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .