Just today-yesterday I started to see the following text almost on each second page I open in Safari. How to disable this?

"App of the Day is a feature of Pet Match and uses visual search technology to find you relevant and related content from thousands of sites across the web. Just click on or hover over the orange InSite icon to open this window and discover related content. To disable this feature, click here. If you wish to share any feedback on this feature, contact us at feedback@similarproducts.net App of the Day"

P.S. Opera looks fine meanwhile.
P.P.S. Also Safari now opens some pages much slower then Opera.


This is spam, introduced by an extension, through superfish.com. AdBlock is not the cause! AdBlock blocks the injected ad, so the extension inserts the text equivalent.

Disabling AdBlock will remove the text, because it allows the original injection to take place, and will decrease page load time as the secondary text injection is no longer required.

Enable AdBlock so that the text is shown, then disable other extensions that you have enabled, until the text is no longer inserted.

There is a thread over on adblockplus.org regarding this and including a list of extensions (for Chrome) that caused this for people:

  • Ok. I guess goPhoto was the reason. – klm123 Jul 21 '14 at 21:15

Disabling AdBlock extension in preferences seems to help with both the text and speed.

But I still don't understand what was the problem, AdBlock worked for me normally for months.


I use Mozilla Firefox on Windows 7. I removed FastestFox and WindowShopper, and the problem went away. Do NOT remove AdBlock, as the latter is doing it's job by only allowing the "App of the Day" message to show, rather than allowing those two add-ins to work. This would appear to be new code in those two add-ins, per forum posts on MalwareBytes website.


Removed FastestFox. Solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .