My Mom's iPhone used to be synced to my computer, a Mac. She recently got a new computer, a Windows laptop, so I set that up for her. I did a sync to the Windows laptop and that seems to work fine except that none of the existing music was deleted. I.E. We want it to be deleted.

When I try and sync all her music on the laptop, it complained that there was not enough space even though her entire library is less than half the phone's capacity.

Syncing an existing album duplicates the album inside Music. Syncing a new albums copies over the new album and that is manageable through iTunes. No existing music can be deleted. When I check "Manually manage music and videos", none of the existing music appears.

At the moment I have the following options checked:


  • Automatically sync when this iPhone is connected

  • Sync only checked songs and videos

Sync music

  • Selected playlists, artists, albums, and genres

    • <Selected a new album>

The following questions do not help.

Device info

  • iPhone 4
  • iPhone iOS 7.1.2
  • iTunes for Windows - just downloaded from website, I assume it is the latest but I cannot find "About"
  • Does this answer solve your problem?
    – sayzlim
    Commented Jul 19, 2014 at 17:35
  • I suppose that is a possible work around, but surely there is an automated way?
    – Megasaur
    Commented Jul 22, 2014 at 2:13
  • Can you manually move the music in iTunes to your mother’s iPhone? Not syncing, but manually drag and drop to the iPhone on the iTunes’s sidebar.
    – sayzlim
    Commented Jul 22, 2014 at 5:29
  • Any new syncing works. I can set the manual management too. It's just the existing music that does not get synced. Deleting all the music and starting over may be what we have to do...
    – Megasaur
    Commented Jul 24, 2014 at 3:46

1 Answer 1


I had the exact same issue when setting up a new computer—frustrating. What's happening is that iTunes sees that the current songs on the iPhone are taking up a lot of space, but iTunes is unable to figure out that many of the songs that are already on the iPhone are the same ones that are in your iTunes. Instead of syncronizing it to make all the songs match, it's saying there isn't enough space on the iPhone to add all of the songs in your iTunes library.

Based on a couple of posts I read on the web, I just tried this solution and it worked:

  1. Make sure you have all of your songs organized the way you want them in iTunes on your computer.
  2. Connect your iPhone to your computer and sync your iPhone with iTunes, but on the music tab in iTunes, uncheck "sync music." Set up all your other synchronization settings as you want them (Calendars, Contacts, Photos, Podcasts, etc). This way everything but your music will be correctly synched between your iTunes and iPhone. Once you have iTunes set to sync, click "Apply" in lover right corner of iTunes. This will sync everything except your music.
  3. Next, you need to erase all of the songs on your iPhone. If there are any songs on your iPhone that aren't in your iTunes, you'll lose them, but that wasn't the case with me. To erase songs on iPhone, go to Settings → General → Usage → Manage Storage → Music → Edit (top right of screen). Click the red "-" to the left of "all songs" and tap delete. Scary, but this will delete all songs on the iPhone itself.
  4. Not sure if it's necessary but I restarted my iPhone after this.
  5. Connect your iPhone to your computer. Click on the little iPhone icon in the top left of the iTunes screen, and then click the Music tab in iTunes. Put a check in the box by "Sync Music" and then select whether you want to sync your entire library or selected playlists, artists, etc. Once you've selected what you want to sync, click on "Apply" in the bottom right corner of iTunes.

This will dump all of your iTunes songs/playlists back into your iPhone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .