1

I recently installed update 10.9.4, which was recommended for all Mavericks users. My wifi was working fine beforehand and now won't connect to familiar networks. Ironic much? The 10.9.4 update was supposed to fix wifi problems for Mavericks!

I have tried various troubleshooting approaches and nothing works. My mac is able to see the network but not connect to it. When I try, it just says "The network _____ could not be joined" and then gives me the option to run diagnostics, which does not help. I've tried resetting the SMC and PRAM, deleting the contents of the system config folder, and of course have restarted the machine several times. I've deleted the bluetooth config file, deleted and re-added the wifi in network preferences and renewed the DHCP lease. I'm afraid I'm out of ideas.

  • I have a Mac Book Pro with 10.6.8, fully functional until yesterday. I've upgraded to 10.9.4 and now the Wi-fi is dead, not even connects or show the avaiable nets. The icon says on tooltip there are no hardware installed. Please let me know if you got any success. I'll do the same. – user85256 Jul 17 '14 at 13:26
  • Did you try deleting the misbehaving Wifi network from the list of Preferred Networks in Network Preferences and starting from scratch? Please give a bit more detail about the troubleshooting techniques you tried. – IconDaemon Jan 5 '15 at 14:03
1

I would try to manually connect to network to see if that works.

Here are the steps how to do that using Terminal by copy/paste following:

Turn On

networksetup -setairportpower en0 on

Find

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD
0

I was having regular issues to connect to home wifi network with Maverick 10.9.3. I upgraded to 10.9.4, now i have systematic issue. It takes me at least 10-15 times entering the same password to get connected. But at least at the end i have connection...

You must log in to answer this question.

protected by bmike Jan 5 '15 at 14:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .