0

I'm using a Seagate GoFlex that seems to have encountered some trouble. The drive does not appear on the desktop or Finder. I've double checked that Finder > Preferences allows for it to appear in both places.

I can see the drive in Disk Utility and have successfully done 'Verify Disk' and 'Repair Disk' however it's worth noting that both 'Verify Disk Permissions' and 'Repair Disk Permissions' are greyed out.

The "Mount" option at the top of Disk Utility is greyed out, however "Eject" is not though when selected I receive that it "could not be unmounted."

I don't quite know what to do next in order to successfully access the Time Machine backups and other files I have stored.

  • Open Console.app in Applications>Utilities. Then, open disk utility and try to click the mount button. Some errors will probably appear in the console immediately following that. Copy and paste those errors here. Also, how is the disk formatted? (exFAT, FAT32, Mac OS Extended, NTFS?) – Alex Jul 15 '14 at 3:15
  • Mount is not even an option - it's greyed out. How do I check how it's formatted? – AMC Jul 15 '14 at 3:38
  • Some basic questions: Have you disconnected the drive and rebooted? Do you by any chance have any other computer you can try it on? Have you tried using diskutil from the command line? – Hank Jul 15 '14 at 4:57
  • I last used the drive about a month ago. Tried to back up a few days ago, it wouldn't work so I put it away. Got it back out today - problem persists. • Yes; disconnected, rebooted computer. No improvement. • No other computer to test. • I'll try diskutil from command line, thanks. – AMC Jul 15 '14 at 5:02
  • It looks like this might be what I want to use, but how and in what context? "eject - Eject a removable disk" – AMC Jul 15 '14 at 5:04
1

The hard drive randomly started working again after an hour or so left alone.

  • 3
    Time for a new drive then, if you have anything valuable on it... – nohillside Jul 15 '14 at 6:25
0

I had this exact same problem. My SeaGate GoFlex was working great, but then mysteriously disappeared from Finder and couldn‘t be repaired in “Disk Utility.”

What finally worked, after opening up “Activity Monitor” application, I noticed there was a “Seagate Utility Gauge” process running. After Googling that, I noticed other people were uninstalling it. Out of desperation, I found a folder which contained the “Seagate Utility Gauge”:

Library/Application Support/Seagate

I dragged the folder to the trash, then used the “Force Quit” option on the process in “Activity Monitor,” and voila! it worked instantly! Give it a whirl and maybe it will fix your issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .