234

How do I stop the Adobe Creative Cloud app from auto-launching on login? I don't see any option of stopping this, and for some reason it's not in OS X's user login options.

  • 8
    I noticed I got this problem when I stopped using The Pirate Bay version and started using the paid version of Adobe products :-( – William Entriken Sep 5 '17 at 19:42
  • 1
    We have this issue continually and since the CC app has so many versions, we might need another question to address a specific version of the CC App. Even with enterprise licenses to Adobe, this is problematic to manage. – bmike Apr 6 at 17:50
353

It is loaded by default by /Library/LaunchAgents/com.adobe.AdobeCreativeCloud.plist.

If you run

launchctl unload -w /Library/LaunchAgents/com.adobe.AdobeCreativeCloud.plist

that will disable it for your user.

To turn it back on

launchctl load -w /Library/LaunchAgents/com.adobe.AdobeCreativeCloud.plist
  • 3
    This worked really well! Just wondering, is there a way to make this apply to the guest user account as well? – user1434077 Oct 23 '14 at 17:43
  • 2
    After unloading it you can also delete the .plist and banish Adobe forever! (Or until next update :) – kakubei Apr 24 '15 at 14:48
  • 11
    Works great. Then just sudo rm /Library/LaunchAgents/com.adobe.AdobeCreativeCloud.plist to get rid of it entirely. – Avishai Dec 2 '16 at 16:44
  • 8
    Don't forget to also unload the Adobe Updater, which runs in the background too: launchctl unload -w /Library/LaunchAgents/com.adobe.AAM.Updater-1.0.plist – Daniel van Flymen Feb 5 '17 at 22:32
  • 3
    I created a Gist for a bash script. Just download it and run it. Feel free to add more processes to it in the future: gist.github.com/WadeShuler/670a281c1c29ab1aebb94a21798db155 – Wade Apr 25 '17 at 20:48
41
  1. Click on the menu bar icon.

  2. Click the ellipsis icon at the top-right.

  3. Select “Preferences” ellipsis menu

  4. Uncheck “Launch at login”.

    preferences

  5. Note: The “Preferences” option does not appear until you log in to Creative Cloud.

  • 102
    What a scummy application to make you accept the terms and login before disabling it – user43892 Mar 5 '15 at 15:47
  • 9
    Preferences are no longer even there in Creative Cloud. Adobe is getting worse every day! – kakubei Apr 24 '15 at 14:47
  • 2
    That's interesting, on my machine I got nothing at all. – kakubei Apr 28 '15 at 9:09
  • 16
    The 'Launch at login' only apply to the menulet UI. Check your Activity Monitor and you will see there are bunch of background Creative Cloud still leaching your resources. – DazChong Dec 16 '15 at 3:25
  • 2
    I created a Gist for a bash script. Just download it and run it. Feel free to add more processes to it in the future: gist.github.com/WadeShuler/670a281c1c29ab1aebb94a21798db155 – Wade Apr 25 '17 at 20:49
12

To turn off everything Adobe launches at startup on the Mac you need to both disable its launchd jobs and the Adobe Core Sync extension.

For the Adobe Core Sync extension, it is a Finder Sync extension so you can disable it under System PreferencesExtensions as described in this answer - https://apple.stackexchange.com/a/237585/23876. From what I have seen, you will need to repeat this step after each Adobe Creative Cloud upgrade.

For the launchd jobs, read on. Note that the following will also disable Adobe automatic update checking. So you will need to check for updates from inside one of the Adobe apps or explicitly run Adobe Create Cloud.

Adobe actually puts their launchd job definitions in several places and those places change depending on the Adobe version. Building on @Alan Shutko’s answer, the following will disable them everywhere. You can ignore any “Could not find specified service” warnings. After running, reboot to enjoy an Adobe free launch (until you actually run an Adobe product).

launchctl unload -w {,~}/Library/LaunchAgents/com.adobe.*.plist
sudo launchctl unload -w /Library/LaunchDaemons/com.adobe.*.plist

As background, launchctl unload -w disables each service in the override database. launchd will follow the override database entry even if the job definition (e.g. /Library/LaunchAgents/com.adobe.AdobeCreativeCloud.plist) is marked as enabled. The override database is on a per user basis. LaunchDaemon jobs are run as root so we use sudo to disable them for the root user.

From what I have seen so far, Adobe installs do not update the override database, so you shouldn't need to run the commands again after an Adobe install (unless they introduce another job). Please comment if someone does see Adobe touching the override database.

For more information on launchd, the launchd Tutorial is a great overview on launchd jobs. And LaunchControl is a good tool for working with launchd jobs. LaunchControl is a paid app, but the trial version supports viewing them. Be sure to enable tooltips so you can see the override database values.

0

I'm currently using this set of commands—the wildcard answer will be a bit more future-proof if Adobe adds more services, but:

  1. Apple is shifting to having these services embedded inside app bundles, so new services added by Adobe may not appear in the usual /Library/Launch*/ paths but still have the same infuriating launch-at-login behavior and
  2. this answer lets you target a single user (if you have multiple users on your machine) for the Creative Cloud UI and sync daemon, should you wish to leave them in place for another person.
sudo launchctl disable system/com.adobe.acc.installer.v2
sudo launchctl disable system/com.adobe.acc.installer
sudo launchctl disable system/Adobe_Genuine_Software_Integrity_Service
sudo launchctl disable system/com.adobe.AdobeCreativeCloud
sudo launchctl disable system/com.adobe.agsservice
launchctl disable gui/$(id -u)/com.adobe.acc.AdobeCreativeCloud.2416
launchctl disable gui/$(id -u)/com.adobe.accmac.2256
launchctl disable gui/$(id -u)/com.adobe.CCXProcess.2252
launchctl disable gui/$(id -u)/com.adobe.CreativeCloud
launchctl disable gui/$(id -u)/com.adobe.CCLibrary.4032
launchctl disable gui/$(id -u)/com.adobe.AdobeCreativeCloud

You must log in to answer this question.

protected by Community Aug 4 '15 at 14:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .