2

Since I've updated to Mavericks from Snow Leopard recently, I've noticed that some apps that I download (not from the App Store) won't launch. When I used chmod 775 on them, I could launch them. It seems some apps get wrong permissions upon downloading?

Why can't I open only certain apps, and how can I prevent it?

  • 1
    I should probably note that these weren't some shady apps, just a trial version of a vector app for example. – Linda Jul 14 '14 at 16:55
1

Mavericks has an extra security mechanism, Gatekeeper, in System Preferences->Security & Privacy->General you can allow apps downloaded from: Anywhere.

  • That was the first thing I did when I installed 10.9, I download apps all the time and it only happens to some of them. I can't find a pattern... It's a permission issue, I'm 99% sure, but repairing does nothing. – Linda Aug 20 '14 at 16:49
  • Example of a download? – bbaassssiiee Aug 20 '14 at 21:03
  • The vector app I've mentioned was a trial of Sketch 3, worked now though. – Linda Aug 20 '14 at 21:42
0

Make sure the permissions/ACLs are set correctly on the /Applications directory.
Run Permissions Repair from Disk Utility to fix this.

  • I ran the apps from the /Downloads or /Desktop folder, is /Applications special in some regard? – Linda Jul 14 '14 at 17:35
  • @Linda (I presume you mean ~/Downloads or ~/Desktop) Not really special, but being outside of your home directory it has ACLs that set the permissions on any apps put there. Whilst apps outside of this folder should work fine, if the permissions/ACLs are wrong on the containing folder then the app may not work correctly. To reset ACLs on your home folder, use the ACL tool. – grg Jul 14 '14 at 17:38
  • 1
    I did the ACL tool thingy, and it still didn't work :( Then I ran ´chmod -R 0755 appname.app´ and it launched... The app is in my ~/Movies folder (I download stuff all over the place...) – Linda Jul 14 '14 at 17:58
0

OSX Snow Leopard included Rosetta, a way to run apps compiled for the PowerPC cpu on the Intel cpu. Mavericks lacks this. Run the lipo command with info option on the binary in the app package to find the supported architectures.

  • 1
    Definitely not PowerPC apps, they won't ever start on Mavs even with correct permissions and the app icons are crossed out. – Linda Aug 20 '14 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .