3

I'm unable to connect to any WiFi network. When attempting to connect, before the popup prompting me to run network diagnostics, the console shows the following in the logs:

7/14/14 8:52:06.000 AM kernel[0]: ARPT: 1668.667864: MacAuthEvent en0   Auth result for: 00:1f:f3:c1:c1:5a Auth timed out
7/14/14 8:52:09.000 AM kernel[0]: ARPT: 1671.337424: directed SSID scan fail

I was able to connect to a network briefly after disabling Bluetooth, but the activity resumed shortly after.

The network card appears to be on:

    $ networksetup -getairportpower en0
      Wi-Fi Power (en0): On

and connecting with a USB ethernet adapter is fine, so I suspect the issue is limited to the wireless adapter.

This is occurring on a late 2013 13" MacBook Pro (2.4 GHz i5, 8 GB memory 1600 MHz DDR3) running 10.9.4.

I found a number of similar threads, with similar symptoms, however, the key difference was that the Auth result had succeeded, and the issues were occurring after succeeding and initiating the next phase of the connection. This is happening on ALL wireless networks, with other devices able to connect without issue.

Has anyone seen this before? If it's failing to pass this step, is there the possibility of a network-hardware issue?

UPDATE:

Was unable determine the source of the issue, but resetting PRAM and NVRAM seems to have fixed it. Apple suggested using a new network location, but this worked only intermittently.

  • Just had this problem, and resetting NVRAM resolved it for me. – user543459 Feb 24 '15 at 15:44
2

It might be your WiFi hardware, but you can test it using following steps to manualy onnect:

Manually connect to WiFi

Turn On

networksetup -setairportpower en0 on

Find

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Connect

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

If above does not work you have a deeper problem.

  • Before you go, try using the BSSID instead the network name.

airport -A=ssid -BSSID=bssidname -password=password

If you do not know the BSSID (who does), use this to find it:

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport -s

This will give you all SSID and BSSID in your scan range.

  • 1
    Yeah, looks like it might be deeper: $ networksetup -setairportnetwork en0 network_name Failed to join network network_name. Error: -3905 Timeout error and same console error. – tony_perkis666 Jul 14 '14 at 14:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .