1

I copy OSX system with another SSD, and when want open file, you can see following, that means I can open file with the application in deprecated osx, but I want keep osx for restore oneday. how not show them.And I was confused always. enter image description here

1
  • Grammar check. Please.
    – Alexander
    Jul 14 '14 at 0:04
1

If you don't want the older applications on your backup drive to appear in the Open With menu you could drop the Applications folder of the backup drive in the "Prevent Spotlight from searching these locations" box within the Spotlight Privacy tab within System Preferences.

When Spotlight removes them from the index they should be removed from LaunchServices services as well. If after an short while they haven't disappeared then you might need to give LaunchServices a little nudge with the command from Chris Magnussen's answer.

0

You should reset your Open With menu by rebuilding your Launch Settings database.

  1. Open Terminal (Applications > Utilities)
  2. Copy and paste: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
  3. Hit enter and wait for a few moments as the command is processed.

Now, you should not have duplicates in your Open With menu.

1
  • do not forget to use this command (killall Finder) after the above command, otherwise your issue still exist.
    – laughing
    Oct 31 '19 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .